Windows XP Start Menu shows "Firefox" instead of "Mozilla Firefox"

RESOLVED INVALID

Status

()

Firefox
General
--
trivial
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Seth Kinast, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

As per Name Change FAQ @
http://www.mozilla.org/projects/firefox/firefox-name-faq.html: "The official
name is Mozilla Firefox. We will often shorten that to Firefox."

On the Windows XP Start Menu, the user has an option to show the default
Internet and Mail applications. If Firefox is set as this default application,
its caption reads "Firefox" rather than "Mozilla Firefox".

Reproducible: Always
Steps to Reproduce:
1. Set Windows XP to NOT use Classic Start Menu (use XP-only Start menu)
2. Set Firefox as preferred Internet application so that it will appear in the
Start menu.
3. Click Start.
Actual Results:  
Firefox appears, captioned as "Firefox".

Expected Results:  
Caption should be "Mozilla Firefox".

Comment 1

14 years ago
I'd think this is OK. "Mozilla" is probably there just to preserve any small
brand recognition already gained, and it's probably in front of the browser
partly because that's what they had to do with Mozilla Firebird, formerly
Firebird, formerly Phoenix.

I'd say it's OK and that it's comparable to shortening Microsoft Internet
Explorer to just Internet Explorer. On the other hand, Mozilla Firefox isn't
terribly long, and they could probably fit it if they wanted to--but they
probably have their reasons.
(Reporter)

Comment 2

14 years ago
True. I remember this sticking out like a sore thumb going from "Mozilla
Firebird" in the menu to just "Firefox", but maybe it's just me.

Comment 3

14 years ago
FWIW, I expect WinXP is simply showing the Product Name from the EXE's version
table, see http://lxr.mozilla.org/mozilla/source/browser/app/module.ver

Comment 4

14 years ago
not a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
The entry in the Start > Programs menu says "Mozilla Firefox", so if the
application is pinned to the Start Menu as "any" application, it's shown as
Mozilla Firefox. If the user's default browser is shown on the Start Menu, the
application's Product Name is used - "Firefox".

This is inconsistent and possibly confusing to users who don't care whether it's
their default browser or Firefox on their Start Menu (the difference is
trivial). Also, "Firefox" is inconsistent with "Mozilla Thunderbird".

Pick one - Either use "Firefox" in the Programs menu, or use "Mozilla Firefox"
as the application's Product Name. I don't mind which name is used (personally I
prefer the full version) as long as it's used consistently throughout the Start
Menu.

(I suggest the "polish" keyword for this bug)
(Reporter)

Comment 6

14 years ago
Created attachment 150229 [details]
screenshot showing Firefox vs. Thunderbird on Start Menu

I think this showcases the inconsistency fairly well.
(Reporter)

Comment 7

13 years ago
Fixed sometime along the way. Guess it wasn't *too* invalid :P
You need to log in before you can comment on or make changes to this bug.