Crash if Java not correctly installed and tab/window closed before OKing failure messagebox

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED WORKSFORME
14 years ago
7 years ago

People

(Reporter: Laurence "GreenReaper" Parry, Assigned: Alfred Peng)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

If the Java runtime environment is not correctly loaded, the following message
box will appear
---------------------------
Java(TM) Plug-in Fatal Error
---------------------------
The Java Runtime Environment cannot be loaded from <\bin\hotspot\jvm.dll>
---------------------------
OK   
---------------------------

If you close the window before clicking OK, the browser (Firebird or Mozilla)
will crash (firefox.exe or gklayout.dll as appropriate).

Reproducible: Always
Steps to Reproduce:
1. Mess up your java install (eg by renaming the directory it is in)
2. Load up firebird or mozilla, get it to go to a page with a Java applet on
3. Close the tab/window before OKing the warning box
4. Click OK

Actual Results:  
The browsers crashed.

Expected Results:  
Nothing - the window/tab is closed, it should not try to change anything on what
is presumably a deallocated window.

The following debug information was provided on crash:

AppName: firefox.exe	 AppVer: 0.8.0.0	 ModName: firefox.exe
ModVer: 0.8.0.0	 Offset: 002586a7

AppName: mozilla.exe	 AppVer: 1.7.20040.12109	 ModName: gklayout.dll
ModVer: 1.7.20040.12109	 Offset: 00188a37

Stacktrace attached.
(Reporter)

Comment 1

14 years ago
Created attachment 141583 [details]
Stacktrace of crash in Mozilla 1.7a

Comment 2

14 years ago
> 1. Mess up your java install (eg by renaming the directory it is in)

Hmm... what's this! If you renamed your windows directory, your WinXP won't
start up. Is that a bug?

You should file a bug about "Java runtime environment is not correctly loaded". why?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

14 years ago
You are missing the point. Mozilla/Firefox is meant to handle this case by
placing a "can't load the Java runtime/missing plugin" image into the plugin
after it displays the error message. _Normally_ it does this fine. However if
you close the tab first it *still* tries to do this, but since the tab/window is
now not there it crashes instead. I am saying that it should not crash,
especiallly as it doesn't when you don't close the tab first.

The situation is more like "if you try and run an application, and it is not
present, Windows crashes (taking all of your other applications with it)". If
you think about it that way I'm sure you can see that that's not the right thing
for Windows to do, even if the user messed up somehow by deleting the
application without telling Windows. :-)

If this is not the right component to file this bug under, then I apologise - I
am not highly familiar with the different components. If you know what that
component is, please feel free to change the component (or tell me which one to
change it to if you cannot). But it *is* a valid bug.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

13 years ago
This happens with Firefox too.... :(

Comment 5

13 years ago
I experience something like this, but not exactly the same:

when a page is loading in a tab that uses Java and I close the tab before the
applet has been initialized, Firefox starts consuming extremely large amounts of
memory and keeps trying to initialize an applet in a tab already closed. The
side effect is that closing Firefox does NOT stop the service firefox.exe on
WIndows XP SP 2.

Updated

13 years ago
Keywords: crash

Updated

12 years ago
Assignee: yuanyi21 → pete.zha

Comment 6

12 years ago
mass reassign to Alfred
Assignee: zhayupeng → alfred.peng

Updated

11 years ago
Blocks: 353557

Updated

11 years ago
No longer blocks: 353557
this can not be reproduce by us
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago9 years ago
Resolution: --- → WORKSFORME

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.