Graphical emoticon should show a tooltip with the textual emoticon

VERIFIED FIXED in seamonkey2.0a1

Status

SeaMonkey
MailNews: Message Display
--
enhancement
VERIFIED FIXED
15 years ago
9 years ago

People

(Reporter: Tobias Burnus, Assigned: Cédric "chewey" Menge)

Tracking

Trunk
seamonkey2.0a1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

15 years ago
If 'Display emoticons as graphics' is shown, then :-) etc. are converted into
graphics. But sometimes one does want to see the original typeset thing (e.g. if
something is shown as emoticon which is not ment as one).

ChatZilla offers a tooltip showing the original typed text, unfortunally
Mail&News doesn't.

Updated

15 years ago
Severity: normal → enhancement
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Updated

12 years ago
Depends on: 335344

Comment 1

12 years ago
Created attachment 219774 [details] [diff] [review]
show html tooltips in messagepane, v1

I'm not quite sure if linking a navigator file inside mailnews is a good idea - otoh I don't know why browser.js is in navigator in the first place:
I'd expected it somewhere along browser.xml in global...

Anyway, when smilies have gotten a title attribute by bug 335344, this will show it as a tooltip.
Assignee: mail → mnyromyr
Status: NEW → ASSIGNED
Attachment #219774 - Flags: review?(neil)

Comment 2

12 years ago
Comment on attachment 219774 [details] [diff] [review]
show html tooltips in messagepane, v1

From IRC: FillInHTMLTooltip (and possibly aHTMLTooltip) needs to move (probably to utilityOverlay.js) and the other two message windows also need to be patched.
Attachment #219774 - Flags: review?(neil) → review+

Updated

12 years ago
Summary: Graphical emoticon should show a tooltip with the textial emoticon → Graphical emoticon should show a tooltip with the textual emoticon

Comment 3

12 years ago
*** Bug 318702 has been marked as a duplicate of this bug. ***
(In reply to comment #2)
> (From update of attachment 219774 [details] [diff] [review])
> From IRC: FillInHTMLTooltip (and possibly aHTMLTooltip) needs to move (probably
> to utilityOverlay.js) and the other two message windows also need to be
> patched.

Does FillInHTMLTooltip still need to move to utilityOverlay.js?

Comment 5

11 years ago
The fundamental problem (linking a navigator file inside mailnews) is still there, so this means most probably "yes". But I didn't look into this since then.
(Oh my, I really let that dangle for more than a year? :-( )
(Assignee)

Comment 6

11 years ago
Created attachment 283928 [details] [diff] [review]
Show emoticon tooltip in message window and messenger.

This enables the tooltips for emoticons in both messenger.xul and MessageWindow.xul.

FillInHTMLTooltip() is moved from browser.js to a more generic location in contentAreaUtils.js - from where it still can be used by all necessary files.
Assignee: mnyromyr → bugzilla
Attachment #219774 - Attachment is obsolete: true
Attachment #283928 - Flags: superreview?(neil)
Attachment #283928 - Flags: review?(neil)

Comment 7

11 years ago
Comment on attachment 283928 [details] [diff] [review]
Show emoticon tooltip in message window and messenger.

The idea looks good but when I tried it it broke tooltips entirely in Editor (and note that Editor uses different tooltips anyway).
Attachment #283928 - Flags: superreview?(neil)
Attachment #283928 - Flags: review?(neil)
Attachment #283928 - Flags: review-
(Assignee)

Comment 8

11 years ago
Created attachment 284354 [details] [diff] [review]
same as above + fixed editor.xul issue

Fixed editor issue by renaming the offending function from FillInHTMLTooltip() to FillInHTMLTooltipEditor()
Attachment #283928 - Attachment is obsolete: true
Attachment #284354 - Flags: superreview?(neil)
Attachment #284354 - Flags: review?(neil)

Comment 9

11 years ago
Comment on attachment 284354 [details] [diff] [review]
same as above + fixed editor.xul issue

>+  <tooltip id="aHTMLTooltip" onpopupshowing="return FillInHTMLTooltipEditor(this);"/>
For bonus points work out how to use "normal" tooltips for Composer's sidebar :-)
Attachment #284354 - Flags: superreview?(neil)
Attachment #284354 - Flags: superreview+
Attachment #284354 - Flags: review?(neil)
Attachment #284354 - Flags: review+

Comment 10

11 years ago
Landed on trunk.

Many thanks, Chewey, for cutting this loose end here!
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Target Milestone: --- → seamonkey2.0alpha
Duplicate of this bug: 60825

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.