If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Change download destination/filename during download

RESOLVED WONTFIX

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED WONTFIX
14 years ago
9 years ago

People

(Reporter: gkn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.6) Gecko/20040206 Firefox/0.8

While a file is downloading, one should be able to change its destination (via
the existing Properties dialogue).

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
I would think this would be an enhancement rather than a 'broken behavior' bug
as there doesn't seem to be any expectation to be able to change this (with the
possible exception of the Mac).

References:
http://www.mozilla.org/projects/firefox/ue/downloads/
http://www.mozilla.org/projects/ui/navigator/downloads/
If you have ask before downloading selected, it should do this.  The default is 
to use autodownload.
QA Contact: mconnor
(Reporter)

Comment 3

14 years ago
I figured it was a "minor loss of function" and there was an "easy workaround".
I suppose it's also an enhancement.

Updated

14 years ago
Severity: minor → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
i'm not sure if you mean _durring_ download, or at start of download.

I agree that selecting where to place the file should be default behavior
I also agree that this would be a really neat feature..
(Reporter)

Comment 5

14 years ago
(In reply to comment #4)
> i'm not sure if you mean _durring_ download, or at start of download.
> 
> I agree that selecting where to place the file should be default behavior
> I also agree that this would be a really neat feature..

I mean during download - you can choose to be prompted for file locations
already. This bug isn't about the default download location.

Comment 6

13 years ago
*** Bug 247392 has been marked as a duplicate of this bug. ***

Updated

13 years ago
OS: Windows XP → All
Hardware: PC → All

Comment 7

13 years ago
(In reply to comment #4)
> i'm not sure if you mean _durring_ download, or at start of download.
> 
> I agree that selecting where to place the file should be default behavior
> I also agree that this would be a really neat feature..

that's bug 237093 (WONTFIX'ed)
*** Bug 309836 has been marked as a duplicate of this bug. ***
Assignee: bugs → nobody
QA Contact: mconnor → download.manager
a=mconnor
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX

Updated

10 years ago
Duplicate of this bug: 389802
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.