xft crash with unicode character 478 [@ nsFontMetricsXft::DrawString ]

RESOLVED DUPLICATE of bug 213734

Status

Core Graveyard
GFX: Gtk
--
critical
RESOLVED DUPLICATE of bug 213734
14 years ago
9 years ago

People

(Reporter: Martin Burchell, Assigned: blizzard)

Tracking

({crash, testcase})

Trunk
x86
Linux
crash, testcase

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040216

When visiting this page or the cut-down example I'm about to attach, Mozilla
crashes.

The problem appears to be with the Unicode character 478 - Latin Capital Letter
A With Diaeresis And Macron but I didn't bother to check if any other characters
could also be responsible.


Reproducible: Always
Steps to Reproduce:
1.Load the page
2.Scroll down to the section: Other selected Unicode characters from the
"Minimum European Subset"


Actual Results:  
Mozilla crashed


Expected Results:  
Not crashed


I'll attach stack trace, test case and build config.

I got the crash for the following fonts:
Arial, Arial Black, Bitstream Charter, Century Schoolbook, Comic Sans MS,
Courier, Courier 10 Pitch, Courier New, Georgia, Impact, Luxi Mono, Luxi Sans,
Luxi Serif, Nimbus Mono L, Nimbus Roman No 9 L

I didn't get the crash for LucidaTypewriter

I got bored so I didn't check all the fonts.
(Reporter)

Comment 1

14 years ago
Created attachment 141623 [details]
test page
(Reporter)

Comment 2

14 years ago
Created attachment 141624 [details]
about:buildconfig
(Reporter)

Comment 3

14 years ago
Created attachment 141625 [details]
backtrace
Assignee: nobody → blizzard
Component: Layout: Fonts and Text → GFX: Gtk
QA Contact: core.layout.fonts-and-text → ian

Comment 4

14 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash, testcase
Summary: xft crash with unicode character 478 → xft crash with unicode character 478 [@ nsFontMetricsXft::DrawString ]

Comment 5

14 years ago
It work on Solaris with xft gtk2 

Mozilla 1.7a, Copyright (c) 2003 mozilla.org, build 2004021805
(Assignee)

Comment 6

14 years ago
Dup.

*** This bug has been marked as a duplicate of 213734 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 7

14 years ago
I was under the impression this bug was also fixed on 1.6 branch, no ?
Product: Core → Core Graveyard
Crash Signature: [@ nsFontMetricsXft::DrawString ]
You need to log in before you can comment on or make changes to this bug.