Closed Bug 234677 Opened 21 years ago Closed 21 years ago

Venkman Javascript debugger does not display complete source.

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 229024

People

(Reporter: rlavalle, Assigned: bugzilla)

References

()

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Using the Venkman JavaScript Debugger version 0.9.97 in Firefox 0.8, the source
view does not show all source, but is truncated to only 21 lines of code. The
page contains a couple hundred lines of code.

On a later attempt, Venkman would not show any source code at all.

The same version of Venkman works properly in FireBird 0.7.

Reproducible: Always
Steps to Reproduce:
1. Ensure Venkman 0.9.97 is installed and Firefox is restarted.
2. Open page with javascript like "http://www.grayforge.com/destiny/"
3. launch the Javascript debugger by entering "x-jsd:debugger" in the address field.
4. When Venkman launches, double clock a Javascript function to display it in
the source view. Note that you can't view all source or maybe any.


Actual Results:  
The source view in the Venkman Jacascript debugger showed only a portion of the
page source.

Expected Results:  
Shown all the source on the page.

While this is not a major user feature, it's sure important to developers.
Tested User Agents: 
Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.6) Gecko/20040113
Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.6) Gecko/20040114 

Tested Venkman Version: 0.9.80

I have the same problem: The source code window in Venkman does not show the
whole source. I think that the truncated and shown number of lines differ arbitrary.

Regards
Henning Pingel
this is a duplicate of bug 229024
http://bugzilla.mozilla.org/show_bug.cgi?id=229024
Someone with the right privileges should close this bug as duplicate of 229024.
Resolving dup per comment 2.

*** This bug has been marked as a duplicate of 229024 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Sorry folks. I searched for similar bugs, but could did not find the original bug report.

Russ
You need to log in before you can comment on or make changes to this bug.