Manage Stored Passwords->Remove All (button) when clicked requires a waring pop-up

VERIFIED DUPLICATE of bug 171756

Status

SeaMonkey
Passwords & Permissions
--
critical
VERIFIED DUPLICATE of bug 171756
14 years ago
13 years ago

People

(Reporter: Paul Bergsagel, Assigned: dveditz)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040211

The other day I went to the menu item Tools->Password Manager->Manage Stored
Password. I wanted to delete one password and accidently hit "Remove All"
instead of "Remove" and lost all by password!

I expected that if I either of these buttons, but especially the "Remove All"
button a pop up warning would appear informing the user that if this action is
continued all the stored passwords will be lost. There is no such warning pop-up
which would have informed me that I had not clicked on the remove but the remove
all button and give me the option to back out of the acgtion before I lost all
my passwords.

Fortunately I had a recent backup of my profile and could restore the passwords!

Reproducible: Always
Steps to Reproduce:
1.Go to the menu: Tools->Password Manager->Manage Stored Password
2.Click on the item "Remove All"

Actual Results:  
Dataloss of the all the stored passwords if the user intended to click on
"Remove" and not "Remove All".

Expected Results:  
I expect that when the user clicks on either the "Remove" or "Remove All" button
that a pop-up window would appear to warn the user that either one or all
passwords are about to be deleted and provide the option either to cancel the
action or to continue the action.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 171756 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
verified.

pi
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.