Replace "Show" with "Open" in Download Manager

RESOLVED FIXED

Status

()

RESOLVED FIXED
15 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

15 years ago
...and add Open Containing Folder to context menu.

Comment 1

15 years ago
I would recommend not removing show as a number of people (myself included)
always use this command upon downloading a file as they do not wish to launch
the file straight away. Adding a launch button is bug 227435 . Is this a dupe of
that?

Comment 2

15 years ago
*** Bug 227435 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Depends on: 227502

Comment 3

15 years ago
I've added bug 227502 as a dependency, because the in order to get the "Open
Containing Folder" context menu option working in a user-friendly fashion, we
should fix bug 227502 on Linux/Macintosh.

Assuming that Show == Open Containing Folder in terms of function, the Open
Containing Folder option will suffer the same problem unless the other bug is fixed.
OS: Windows XP → All
QA Contact: aebrahim
Hardware: PC → All

Comment 4

15 years ago
If you have selected "Show download manager when download begins" and not
selected "Close the download manager when all downloads complete" than besides
file name there are two links "Show" and "Remove". But if you right-click than
you get "Open" or double-click than default is open.

Show is equivalent to Open Containing folder.
Open is equivalent to launch program.

I had wanted Open functionality and found that it is already present.
(Assignee)

Comment 5

15 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 6

15 years ago
IMO, the workaround to 'open containing folder' should have been in a readme
somewhere obviously visible.  It's an irritating change in functionality to
people who haven't read this bug report.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.