css background color on <select> only affects drop down part (not visible part)

VERIFIED FIXED in M14

Status

()

Core
Layout: Form Controls
P3
minor
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: Ronald van Kuijk, Assigned: rods (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Overview description:

When the background color of a select is set with css, it only affects the
dropdown part. This is only the case when a select has a drop-down part (so with
size=1, or size completely omitted) An text-input has the background color you
assign it, so you get colored textboxes, but white dropdown menu's.

Using the background color in formvalidation is not possible with these selects.
 (making it red if the user forgot to select something)

Actual results:
Backgroundcolor of <select> is white, with a colored dropdown part

Expected results:
Both have the same color

Steps to reproduce:

1: go to: http://www.abz.nl/test/formlayer.html
2: igore the two alert boxes
3: look at the text input (blue)
3: fill anything in the text input en press 'next layer'
4: look at the dropdown box (white, with blue dropdown part)

Build and dates:
Verified on W95 with the 2000010516 build
Verified on Linux with the 20000108?? build

Updated

18 years ago
Assignee: karnaze → rods

Comment 1

18 years ago
Reassigning to Rod.
(Assignee)

Updated

18 years ago
Target Milestone: M14
(Assignee)

Comment 2

18 years ago
setting milestone
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

18 years ago
fixed the html.css

Comment 4

18 years ago
This Is Not a bug this is some bad web design in the second layer in the second
field on the PC the text color is white and the background is white so its there
but you have to select it to see it. On the mac (os 9) it shows because the
background is grey. 

Comment 5

17 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma

Comment 6

16 years ago
verified on build 2001-08-14-trunk
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.