New messages appear in wrong place in thread view

RESOLVED DUPLICATE of bug 93426

Status

RESOLVED DUPLICATE of bug 93426
15 years ago
10 years ago

People

(Reporter: john.robinson+bugzilla.mozilla.org, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla Thunderbird 0.5 (20040207)

New messages appear at the bottom of the thead even when they don't belong
there, although they are indented correctly for wherever they do belong, so the
graphics look broken, and the thread view is less useful than it ought to be.
This situation remains whenever I go into the thread view throughout a session,
but when I close Thunderbird and restart it, everything's back in the right place.

In my particular circumstances, this is mail, I'm using IMAP, the folder is
copied locally for off-line use, and messages arrive in this particular folder
by filtering from the Inbox.

Reproducible: Always
Steps to Reproduce:
1.Set up circumstances described (IMAP, off-line cacheing, filtering)
2.Send mail to self in reply to second-last message in a thread.
3.

Actual Results:  
Message appeared below the last message in the thread.

Expected Results:  
Message should have appeared below the message it was in reply to.

Images showing the problem attached.
(Reporter)

Comment 1

15 years ago
Created attachment 141693 [details]
Demonstration of problem; Al Maw's message belongs further up.
(Reporter)

Comment 2

15 years ago
Created attachment 141694 [details]
Demonstration of problem; 3 messages belong 3 further up.

Comment 3

15 years ago
It seems to be the same bug that can be seen in Mozilla. I have used Mozilla 0.9 
until 1.5.

I can confirm the problem for news in TB0.5.

Updated

15 years ago
Blocks: 236849
(Reporter)

Comment 4

15 years ago
I have now noticed I don't need to quit and restart Thunderbird to get things in
the right order, just switching to another folder and back again sorts the view
out. I guess this means that (some part of) the thread view code that gets
called on opening a folder isn't getting called when new messages arrive in the
currently open folder.

Comment 5

15 years ago
Confirming for TB 0.5+ and 0.7.1 in news folder.

For me, it's enough to collapse and re-open the thread for correct display.

Comment 6

15 years ago
Yes, I can confirm this in 0.7.1 under XP.  I have noticed it particularly in
newsgroups, rather than in mail, but that is because I use newsgroups interactively.

If you send a reply, then press F5 to update the list, the reply does not appear
under the message it refers to, but at the end of the thread.
It's indented to the correct place horizontally, but just vertically displaced.

How come this is still "unconfirmed"?  it can't be difficult to reproduce.
I see this on OS X often using Thunderbird 0.7. Opening and closing the thread
seems to work for me too, nice workaround.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

14 years ago
Note that a patch is in progress at the dupe.

*** This bug has been marked as a duplicate of 93426 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
No longer blocks: 236849
You need to log in before you can comment on or make changes to this bug.