Reloading document while in print preview uses default style sheet

RESOLVED DUPLICATE of bug 126719

Status

()

defect
--
minor
RESOLVED DUPLICATE of bug 126719
15 years ago
15 years ago

People

(Reporter: rick, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

If you press F5 to reload the document while you're in print preview mode, the
original, *visual* stylesheet is used instead of the print stylesheet. I'm not
sure, but I think this may have something to do with the fact that I have a
<meta> tag in there that says <meta http-equiv="Default-Style" content="Default" />.

Also, I'm not sure if this is because of the reload, but when I try change the
website once I've closed the print preview (via the "close" button) I get an
error message telling me I can't change page whilst printing or in print preview
mode.

Reproducible: Always
Steps to Reproduce:
1. Load URI above
2. Choose "Print Preview" from file menu
3. Press F5 on your keyboard
[Optional 4. close the preview, and try to change page]

Actual Results:  
Default visual stylesheet was used.

Expected Results:  
Print stylesheet should have been used.
Actually, reload should just be disabled in print preview...

*** This bug has been marked as a duplicate of 126719 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.