Problem with SELECT fields when selections have scroll bar

VERIFIED FIXED in M14

Status

()

P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: rzach, Assigned: rods)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Fix in my tree, URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
When a select field has enough OPTIONs so that the drop-down selection menu is
displayed with a scroll bar, and the field is positionied so that the drop-down
will be displayed above the field, not below, then a. clicking in the field
itself rather than on the down-arrow button will display the menu only as long
as mouse button is pressed and b. clicking in the text are of the select field
will cause a spurious selection.

To reproduce:
1. Go to testcase
2. Position browser window so that drop-down on select field is displayed above
 the field.
3. Click in text area (where it says "other")

Actual result: drop-down list is displayed only momentarily, and the selection
changes from "other" to "21"

Expected result: The drop-down should stay displayed until a selection is made
or a click outside the list.  The selection should not be changed from "other"
unless another item was selected.

4. Click on down-arrow button to bring up drop-down list
5. Mouse-over the text field

Actual result: the selection chanegs from "other" to "21"

Expected reult: the selection should not change

This happens in real life, e.g., in the OS select field in the Bugzilla bug
entry form; I'll attach a test case.  The spurious selections happen only when
there are 21+ items in the list.

Linux build 2000.01.08.08
(Reporter)

Comment 1

19 years ago
Created attachment 4087 [details]
testcase

Updated

19 years ago
Assignee: karnaze → rods

Comment 2

19 years ago
Reassigning to Rod.
(Assignee)

Updated

19 years ago
Target Milestone: M14
(Assignee)

Comment 3

19 years ago
setting milestone
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Whiteboard: Fix in my tree
(Assignee)

Comment 4

19 years ago
happens on all platforms. This is an event handling issue. The problem is we
need to know when we clicking in in the combobox or the listbox. Fix in my tree
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

19 years ago
fixed targeting of event.
(Reporter)

Comment 6

19 years ago
Works on Linux build 2000.01.21.08. Mark verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.