nsPrefMigration.cpp(444) : warning C4101: 'rv' : unreferenced local variable

RESOLVED DUPLICATE of bug 90906

Status

Core Graveyard
Profile: Migration
--
trivial
RESOLVED DUPLICATE of bug 90906
15 years ago
2 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

15 years ago
r:/mozilla\profile\pref-migrator\src\nsPrefMigration.cpp(444) : warning C4101:
'rv' : unreferenced local variable

Comment 1

15 years ago
As the function concerned only returns a fixed 'NS_OK' at its
normal return, the variable concerned is unncessary, and the 
patch is small enough to be applied by eye, videlicet:

Index: src/nsPrefMigration.cpp                                                 
                                                       
===================================================================
RCS file: /cvsroot/mozilla/profile/pref-migrator/src/nsPrefMigration.cpp,v
retrieving revision 1.190
diff -u -r1.190 nsPrefMigration.cpp
--- src/nsPrefMigration.cpp     9 Feb 2004 22:48:48 -0000       1.190
+++ src/nsPrefMigration.cpp     19 Feb 2004 05:58:45 -0000
@@ -441,7 +441,6 @@
 NS_IMETHODIMP
 nsPrefMigration::WindowCloseCallback()
 {
-  nsresult rv;
   nsCOMPtr<nsIScriptGlobalObject> scriptGO(do_QueryInterface(mPMProgressWindow));
   if (!scriptGO) return NS_ERROR_FAILURE;

Fixed by bug 90906 comment 100.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 90906
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.