Regression: Loading many tabs causes the window to stop painting

VERIFIED DUPLICATE of bug 204374

Status

()

--
critical
VERIFIED DUPLICATE of bug 204374
15 years ago
15 years ago

People

(Reporter: bogofilter+mozilla, Assigned: bugzilla)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030817 Mozilla Firebird/0.6.1+

After loading many tabs (in my case, 60), the window (client area and
menu/toolbars) stops painting except for certain elements on mouse over.  This
bug did not exist in the Firebird 2003-08-17 nightly I've been using, but does
occur in the Firefox 0.8 milestone and Firefox 2004-02-18 nightly.

Reproducible: Always
Steps to Reproduce:
1. Load a bunch of tabs.  In my case, I'm clicking "Open in Tabs" in a bookmark
folder with 60 bookmarks.
2. Wait for all the pages to load.


Actual Results:  
Window stops painting except for certain elements on mouse over.
(Reporter)

Comment 1

15 years ago
Also note that both Firefox versions were tested with new profiles and no
extensions installed.
Summary: Regression: Loading many tabs causes causes the window to stop painting → Regression: Loading many tabs causes the window to stop painting

Comment 2

15 years ago
Sounds like a GDI problem (bug 184933, bug 205893, bug 204374, etc).  I don't
know what changed between the Firebird 2003-08-17 nightly and 0.8 that would
have caused the problem to get worse.
(Reporter)

Comment 3

15 years ago
I've narrowed down when this problem started to sometime after 2003-09-03 and
before 2003-09-18.  If I can get my hands on builds in that timeframe, I'll
narrow it down further.

Updated

15 years ago
Keywords: regression
(Reporter)

Comment 4

15 years ago
With the one-off builds and the links to the archives, I've narrowed it down to
a 24 hour period between the nightlies on 2003-09-09 and 2003-09-10.

This one works:
http://archive.mozilla.org/pub/firebird/nightly/2003-09-09-08-trunk/

This one doesn't work:
http://archive.mozilla.org/pub/firebird/nightly/2003-09-10-08-trunk/

I don't know enough about the Mozilla code base to do more than guess, but the
check-in at 09/09/2003 11:08 in nsImageWin.cpp to fix bug 216430 seems highly
suspect.

Comment 5

15 years ago
Darin, you've been blamed.

Comment 6

15 years ago
(In reply to comment #2)
> Sounds like a GDI problem (bug 184933, bug 205893, bug 204374, etc).  I don't
> know what changed between the Firebird 2003-08-17 nightly and 0.8 that would
> have caused the problem to get worse.

yes, pick one.. maybe they should all be duped to a single bug.

Comment 7

15 years ago
Darin: what about comment 4?  (The reporter of this bug says at least one case
regressed after those bugs were reported, and blames a checkin of yours.)

Comment 8

15 years ago
Jesse: sorry, i should have said: "my check-in traded one bug for another" ;-)

in some cases, it did make the problems reported in _those_ bugs show up more
often, but for most users my patch improved the performance of moz greatly on
pages with large background images (not uncommon).  the problem is the same as
the bugs reported earlier, and the solution would likely be the same too.

Comment 9

15 years ago
I marked bug 184933 as a dup of bug 204374.  According to bug 205893 comment 46,
it is not a dup of bug 204374.

*** This bug has been marked as a duplicate of 204374 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.