Link to Show Code produces a Java Script error

RESOLVED FIXED

Status

RESOLVED FIXED
15 years ago
4 years ago

People

(Reporter: osavill, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040218

Selecting any of the 'Show Code' links on these pages produces :

Error: Structure is not defined
Source File: http://www.dofactory.com/Patterns/PatternAbstract.aspx
Line: 1044

in the JavaScript console. This is not enough to say if it is an evangalism
problem (good luck, this is a pro M$ site :-(  ) or a genuine bug in Mozilla.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.



Expected Results:  
I.E. displays, in-line, a code snippet and the 'Show Code' changes to 'Hide Code'
> This is not enough to say if it is an evangalism problem

It is, if you look at the source.... ;)
Assignee: general → english-us
Component: JavaScript Engine → English US
Product: Browser → Tech Evangelism
QA Contact: pschwartau → english-us
Version: Trunk → unspecified

Comment 2

15 years ago
I see this also, Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a)
Gecko/20040219 Firefox/0.8.0+

and I get these messages:

JavaScript error:                                                              
                                                              
http://www.dofactory.com/Patterns/PatternAbstract.aspx line 1044: Structure is
not defined

WARNING: not supported for views, file
../../../src/view/src/nsScrollPortView.cpp, line 137
WARNING: not supported for views, file
../../../src/view/src/nsScrollPortView.cpp, line 137
WARNING: not supported for views, file
../../../src/view/src/nsScrollPortView.cpp, line 137
WARNING: not supported for views, file
../../../src/view/src/nsScrollPortView.cpp, line 137

The page has over 700 validation errors. The problem probably lies in the
ShowHide function at the end of this page
(Reporter)

Comment 3

15 years ago
>> This is not enough to say if it is an evangalism problem 
 
> It is, if you look at the source.... ;) 
  
Indeed ! Point taken :-) 

Comment 4

13 years ago
Russell Pellow 9-12-2006 9:54pm EST

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

I took these steps and i was not able to reproduce this bug, perhaps because i am on Windows XP while above are running Linux and Mac OS X

1. Navigate to http://www.dofactory.com/Patterns/PatternAbstract.aspx
(this brings me to a orange and white site that says "Data & Object factory" on the top) 
2. Scroll down till you see "sample code in C#" Then click the "Show code" link
(This expanded and showed some C# source code and turned the link from 
"show code" to "Hide code")


I got the same result when using internet explorer.
(Reporter)

Comment 5

13 years ago
This now seems to be working in the Linux version. I've just tested it with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6.

We could close this or wait for the person who found it on the OSX version to report back.

Comment 6

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060916 Minefield/3.0a1

(In reply to comment #4)
> Russell Pellow 9-12-2006 9:54pm EST
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728
> Firefox/1.5.0.6
> 
> I took these steps and i was not able to reproduce this bug, perhaps 
> because I am on Windows XP while above are running Linux and Mac OS X
> 
> 1. Navigate to http://www.dofactory.com/Patterns/PatternAbstract.aspx
> (this brings me to a orange and white site that says 
> "Data & Object factory" on the top) 
> ...

I see the same, and with no error messages.

(Reporter)

Comment 7

13 years ago
Looks like all is ok now so suggest closure...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.