Need update nsSidebar.js for firefox.

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: matsuba, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.7a) Gecko/20040218 Firefox/0.8.0+

When I add search engine, Firefox's confirm dialog message is incomplete.
%name% in addEngineConfirmMessage that is defined in sidebar.properties is not
replaced.

Related Bugzilla Bug 94404 sidebar needs to be moved to branding
http://bugzilla.mozilla.org/show_bug.cgi?id=94404


Firefox: (No Good)
http://lxr.mozilla.org/mozilla/source/browser/components/sidebar/src/nsSidebar.js#160

Mozilla: (Good)
http://lxr.mozilla.org/mozilla/source/xpfe/components/sidebar/src/nsSidebar.js#271

sidebarName = brandStringBundle.GetStringFromName("sidebarName");  <== Line 275
dialogMessage = dialogMessage.replace(/%name%/, sidebarName);   <=== Line 282

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
I assume you are talking about the dialog displaying something like:

Name: %name%
Search Category: <whatever>
Souce: <whatever>

Right?

Looking at the current sidebar.properties, I don't see %name% anymore, only %title%.

http://lxr.mozilla.org/firebird/source/browser/components/sidebar/locale/sidebar.properties?raw=1
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=nsSidebar.js&branch=&root=/cvsroot&subdir=mozilla/browser/components/sidebar/src&command=DIFF_FRAMESET&rev1=1.4&rev2=1.5

WFM

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a) Gecko/20040502 Firefox/0.8.0+
(Reporter)

Comment 2

14 years ago
I'm very sorry.

I can't reproduce 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a) Gecko/20040503 Firefox/0.8.0+
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.