Browsers other than IE or Netscape 7 are blocked using user agent verification.

VERIFIED DUPLICATE of bug 234836

Status

Tech Evangelism Graveyard
English Other
VERIFIED DUPLICATE of bug 234836
14 years ago
3 years ago

People

(Reporter: Jay Schlackman, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When attempting to access any page on www.powergen.co.uk, "unsupported" browsers
(such as Mozilla) are denied access, with 'helpful' suggestions given as to
which browsers are permitted.

Reproducible: Always
Steps to Reproduce:
1. Attempt to access http://www.powergen.co.uk/ with identified problem version
of Mozilla.

Actual Results:  
Page displays the following:


We have detected that you are running a browser not supported by this website.

We currently support Microsoft Internet Explorer (Version 5.0 or above) and
Netscape Navigator (Version 7.02 or above).

Whilst not officially supported the site can also be used with Opera (Version
7.20 or above) and Konqueror (Version 3.1.1 or above).

Your Current Browser: Netscape
Your Current Version: 0.8

It is recommended that you upgrade your browser to one of the below.
[links to IE and Netscape download pages]

Expected Results:  
Opened the Powergen website. All URLs on the site exhibit this behaviour,
including the account management sections.

Powergen is the UK's largest electricity company. I contacted Powergen customer
support to ask them why Mozilla was blocked when the Mozilla-based Netscape 7
was allowed. I suggested that their policy of outright blocking of other
browsers was harsh and that they could at least allow the user to proceed "at
risk". I received the following response:



Dear Mr Schlackman,

Good afternoon and thank you for your email.

We use a range of different browsers, but Powergen have chosen those two as they
are the most reliable, and common.

I trust this resolves your enquiry sorry I could not be of more assistance.

Regards
		
Valerie Lewis
Powergen Internet Team




A somewhat concise response that I suspect is the result of a management or
support decision, rather than a techincal one.

Technical notes: The restriction does not seem to be based solely on the user
agent. I attempted to access the site by changing the Mozilla user agent to the
following (from IE6):

Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

I was prented with the same error message, telling me that my browser was being
detected as Netscape 4(!)

After a rudimentary look at the script used I was able to 'fudge' a user agent
that did allow me access: MSIE 6.0; Windows NT 5.1

After gaining access all pages displayed flawlessly, as I would expect given
that they support Netscape 7.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 234836 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.