Closed Bug 234915 Opened 19 years ago Closed 18 years ago

"Send Page" opens Outlook instead of Thunderbird

Categories

(Thunderbird :: General, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 202497

People

(Reporter: adwoz, Assigned: mscott)

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040218 Firefox/0.8.0+

After our IT department deployed Office 2003, including Outlook 2003, any
attempt to "Send Page" always opens the Outlook password dialog. I don't use
Outlook! Before the Office 2003 upgrade, send page worked just fine - it opened
a Thunderbird compose window, as expected.

Reproducible: Always
Steps to Reproduce:
1. open any URL
2. right-click-send page (or File->send page)
3. Outlook password window pops up

Actual Results:  
I got really **** off about the Office upgrade.

Expected Results:  
It should have opened a Thunderbird compose window.

I have tried resetting the windows defaults for email and browser with
Thunderbird and Firefox - did not fix the problem.

One interesting point is that when I run IE6 and do a send page, Thunderbird
compose windows opens!
I was running Firebird 0.7 when this bug first appeared.  I uninstalled it and
upgraded to Firefox nightly - problem persists.
In my case, Outlook opens every time I press a mailto link, let alone use the
Send Page option. I see this with 0.8, as well as with today's build. On the
other hand, it doesn't happen on another machine with similar settings. All
tests were done with a fresh profile.

Reporter, do you see this bug with mailto links as well? what program is
configured as your default email handler? check Control Panel -> Internet
Options -> Programs -> E-mail

Prog.
I don't recall trying any mailto links while this problem existed. And yes,
_Thunderbird_ was configured as mu default mailer - as mentioned in my original
report.

Well, I did manage to RESOLVE THE PROBLEM problem by uninstalling and then
installing Thunderbird.

Before that fix, I monitored the windows registry while doing a "send page" and
found that IE and Firefox were accessing different registry keys.  Sorry, I did
capture that info.
(In reply to comment #3)
> Before that fix, I monitored the windows registry while doing a "send page" and
> found that IE and Firefox were accessing different registry keys.  Sorry, I did
> capture that info.

Since I have a computer that reproduces this problem, I can check this myself.
What software would you recommend for intercepting this registry key?

Thanks,

Prog.
I've used many of the SysInternals packages - regmon is one that allows you to
monitor and capture to a log file all registry operations.  I usually setup all
the apps that are to be monitored, then start regmon, clear its log and run your
tests.  

In this case, choose send page at IE or Firefox, email dialog comes up, stop the
logging and save to a file.  repeat for other browser.

The logs a quite verbose but you should be able to see where the mail client is
queried by each browser.

enjoy ;)

http://www.sysinternals.com/ntw2k/source/regmon.shtml
Not sure what method of emailing Firefox is using, but whatever it is, it's up
to Thunderbird to set it.
Assignee: firefox → mscott
Product: Firefox → Thunderbird
To handle Send Page (which is actually "Send Link"), 
Firefox uses the 'mailto' key:
  HKEY_CLASSES_ROOT\mailto\shell\open\command

Altho reporter never deemed it worth mentioning which version of TB he was 
using, it makes some sense that reinstalling a later version would fix the 
problem, because the patch at the dupe reportedly was working at one point.

However, I am unable to get it to work with TB 0.7.

*** This bug has been marked as a duplicate of 202497 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.