Rich Text API commands "hilitecolor" and "backcolor" do not work

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Kevin Roth, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When implementing the Mozilla Rich Text API, the commands "hilitecolor" and
"backcolor" do not work.  The command "hilitecolor" works in Mozilla version
1.3+, and in Mozilla Firebird 0.61-0.7.  

Reproducible: Always
Steps to Reproduce:
1. Visit http://www.kevinroth.com/rte/demo.htm
2. Select some text in the rich text editor control
3. Click the background color icon and select a color

Actual Results:  
Command does nothing.  There is no error or anything.

Expected Results:  
Should have made the background the color selected for the selected text.  If
the "hilitecolor" command is no longer supported, there should be an error
message in the javascript debugger.
(Reporter)

Updated

14 years ago
Summary: execCommand("hilitecolor", false, color) and execCommand("backcolor", false, color) do not work → Rich Text API commands "hilitecolor" and "backcolor" do not work

Comment 1

14 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040622 Firefox/0.9.0+

WFM.

Please try again with Firefox 0.9 or a recent nightly

Comment 2

14 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040727
Firefox/0.9.1+

No response from reporter.

Kevin - if you can reproduce this with a recent branch build, feel free to
reopen this bug and give details. thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

14 years ago
I cannot reproduce this with FireFox 0.9.2.  Looks good!  Thanks!

Kevin
You need to log in before you can comment on or make changes to this bug.