Firefox crashes everytime I try to use my middle mouse wheel to scroll

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Gary, Assigned: Blake Ross)

Tracking

({crash, regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040218 Firefox/0.8

Firefox crashes everytime I try to use my middle mouse wheel to scroll. It
doesn't matter what the url is. I have seen this on every installer build since
the 0.8 release. Don't know if the zip builds are affected.

Reproducible: Always
Steps to Reproduce:
1.Open Firefox
2.Try to use the middle mouse wheel to scroll
3.

Actual Results:  
Firefox crashes everytime

Comment 1

14 years ago
WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040219
Firefox/0.8 though it's affected with bug 234576 about clicking middle-mouse and
crash.

Comment 2

14 years ago
Yes, this sounds very much like bug 234576, they also started to have problems
after 0.8. 

Gary, what mouse do you use?
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> Yes, this sounds very much like bug 234576, they also started to have problems
> after 0.8. 
> 
> Gary, what mouse do you use?

I am using a Logitech Trackball cordless. I just updated to the newest mouse
drivers and it didn't help. The latest build from today is still doing it.
(Reporter)

Comment 4

14 years ago
I just downloaded the zip build from the 20th and it doesn't seem to be affected
by this bug.
(Reporter)

Updated

14 years ago
Severity: normal → critical
Keywords: crash, regression

Comment 5

14 years ago
It also crashes on me everytime I use the middle wheel to scroll.  I have a 
Logitech Track Man Marble Wheel.  I just downloaded the zip build from the 21st 
and it does it also.

Comment 6

14 years ago
Causes both my work and home PCs, both with microsoft mice, one just the plain
old microsoft regular mouse and one with the inteelimouse explorer. Windows 2000
SP4 etc,

My colleague has a logitech / chicony mouse and it works for him

Comment 7

14 years ago
Crash happens for me with Firefox .8, Win2000, Microsoft mouse.

Seems to be related to having the Smooth Wheel extension installed.
(Reporter)

Comment 8

14 years ago
(In reply to comment #7)
> Crash happens for me with Firefox .8, Win2000, Microsoft mouse.
> 
> Seems to be related to having the Smooth Wheel extension installed.

Not for me it doesn't. I don't have the Smooth Wheel extension installed.

Comment 9

14 years ago
System:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
(Windowx Xp Pro - 5.1.2600 Service pack 1 Build 2600)

Config:
MS Intellimouse 5.0 Driver with USB MS Wireless Optical Mouse, Firefox 0.8 release 

Steps:
a. Open Firefox
b. click the middle mouse wheel to open a new tab

Results:
Firefox is minimized to the taskbar but remains running
-----
I uninstalled Firefox, deleted the Firefox install folder, deleted all profiles,
reinstalled Firefox and created a new profile and got the same results.

I have tested this with the 4.12 version of the MS Intellimouse driver and it
yielded the same results.

I uninstalled the MS 4.12 Intellimouse driver, uninstalled the MS 5.0
Intellimouse driver, and Firefox 0.8. I installed a Logitech USB Mouse driver
(compatible with the USB MS Wireless Optical Mouse), then reinstalled Firefox
0.8 and Firefox worked as expected.

It appears there is some kind of conflict with the MS Intellimouse driver when
using a USB mouse and clicking the middle mouse wheel in Firefox. 

I have not tested the ZIP builds but I can if it would be helpful.
IIRC, the new drivers change the default behaviour of clicking the middle mouse 
button.

Are these installs into a clean directory or over top of an existing 
directory?  If over top, please delete the contents of the install directory 
and install into an empty folder.  This WILL be a problem due to changes in the 
prefs architecture.  (This is recommended in many places, and the reason "Safe 
Upgrade" is supposed to be in the installer)
QA Contact: mconnor

Comment 11

14 years ago
Seems to only happen in Windows boxes; Linux is fine.
Confirmed. I have never crashed a Linux Bird or Fox when scrolling with the
mouse wheel.

Comment 13

14 years ago
I get intermittent crashes which I am sure sometimes should be connected to the
mousewheel usage. Is there any way to download or compile a debug build, extract
some crash data from it then post it here? How can I do this? 
Otherwise, it's impossible to provide useful feedback and all we (users) can do
is waiting for the Firefox to come with talkback enabled. Until then, Firefox
cannot be compared to Mozilla or other available browsers wrt to stability.
for those people seeing this crash, if you install into a different directory 
and run Firefox from that location, do you still see the crash?  This seems to 
be a dupe of 234576 and I suspect this is all caused by still having the old 
all.js from FF 0.8 and earlier.  This doesn't have anything to do with the 
profiles, actually, but with the install directory.
(Reporter)

Comment 15

14 years ago
(In reply to comment #14)
> for those people seeing this crash, if you install into a different directory 
> and run Firefox from that location, do you still see the crash?  This seems to 
> be a dupe of 234576 and I suspect this is all caused by still having the old 
> all.js from FF 0.8 and earlier.  This doesn't have anything to do with the 
> profiles, actually, but with the install directory.

I have completely uninstalled Firefox and made sure that the folder is gone.
When I install again, it still will crash. I haven't checked it with the last
couple of builds, but am fixing to download the latest and try it.

Comment 16

14 years ago
> I have completely uninstalled Firefox and made sure that the folder is gone.
> When I install again, it still will crash. I haven't checked it with the
> last couple of builds, but am fixing to download the latest and try it.

Is that installing via the installer or by unpacking the .zip file?  I'd try
emptying the program's directory, unzipping the latest nightly .zip file, and
moving the unzipped files into the appropriate place and trying to run it again.

This solution worked for me.

Phil 

Comment 17

14 years ago
Does anyone have solid system locks due to this?
AO
Gary, please try installing into a different location and running things from 
there.  If you've played with settings though, this might be a profile issue 
for you, where it isn't for most people here.

Comment 19

14 years ago
(In reply to comment #18)
> Gary, please try installing into a different location and running things from 
> there.  If you've played with settings though, this might be a profile issue 
> for you, where it isn't for most people here.

I went and exited out of Firefox, renamed the directory to Firefox_OLD, and then
reinstalled into the Firefox directory.  Lo and behold, I am now able to use the
middle mouse button to scroll without any problems.

I am using a Miscrosoft Intellimouse Explorer using Intellipoint 4.0 software.

Comment 20

14 years ago
I used to have the same crash problem when I pressed the scroll wheel. I got rid 
of Microsoft's .net 1.1 addon and the problem disappeared. I don't have a 
technical explanation other than it worked (for me anyway).

Comment 21

14 years ago
*** Bug 236414 has been marked as a duplicate of this bug. ***

Comment 22

14 years ago
Isn't this bug another clean install issue that should be marked INVALID like
bug 234576 ? Or can anyone reproduce this with a clean install of the latest
nightly?
Yes, it is.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.