can't accept ssl certificate when its authentication failed

RESOLVED DUPLICATE of bug 242275

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 242275
14 years ago
14 years ago

People

(Reporter: nasty, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

can't accept ssl certificate which isn't authenticated/

Reproducible: Always
Steps to Reproduce:
1.type https://www.css.pl/
2.accept certificate
3.you can't (firefox knows better :) )



Expected Results:  
accept certificate, and show me that page

Comment 1

14 years ago
It will also be desirable a button that allows to allways accept the certificate
as valid (also until it authentication failed).

Comment 2

14 years ago
I'm seeing firefox actually block on internal sites we have with certificates
that don't match the host and aren't authenticated.

I know, bad form, but its the way things work..

Comment 3

14 years ago
this really needs to be fixed..... i cannot access any of our devservers since
they have "broken" certificate and trying to access them causes firefox to freeze. 

Comment 4

14 years ago
*** Bug 247074 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
My trouble is with build:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9
The listed page (https:www.css.pl) works for me under Mozilla/5.0 (X11; U; Linux
i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8 but hangs under 0.9. Oh and
should this bug have a severity of "Critical" as it causes the browser to hang?

Comment 6

14 years ago
confirmed on linux, works on w2k (logging onto https://internal-webmin-url-here
here seems to work ok on firefox0.9/w2k, but indeed causes a total freeze on
firefox0.9/linux)?

Comment 7

14 years ago
Yes, true, this happens with Linux every time. Had to revert back to 0.8.. :) 
 
(In reply to comment #6) 
 

Comment 8

14 years ago
moreover; trying to open 'manage certificates' from preferences window -
advanced does not work. when closing preferences window, the browser freezes
completely.

(Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9)

Comment 9

14 years ago
folks, for me at least this is a show-stoppper.  It would bad form for a new
user like me to go change the sev to "blocker" but could someone with more karma
look over the following as well as another detailed post about this on
http://forums.mozillazine.org/viewtopic.php?p=589713#589713 , and upgrade this
bug to "blocker"?

Thanks,

Comment 10

14 years ago
Perusing bugzilla led me to a workaround that solves this problem: Install the
firefox help module
(http://www.mozilla.org/projects/help-viewer/installation.php#firefox)

Comment 11

14 years ago
bug 242275 ?

Comment 12

14 years ago
(In reply to comment #11)
> bug 242275 ?

Yep.

*** This bug has been marked as a duplicate of 242275 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.