If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

freezes while looking for folders on imap server

VERIFIED DUPLICATE of bug 23312

Status

MailNews Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 23312
18 years ago
9 years ago

People

(Reporter: Dawn Endico, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I've never been able to use mozilla with this imap server.
It seems to be confused by my folders. It creates files
for some, but not all. It wouldn't make a folder for my
2mb Sent folder so I moved it out of my personal imap
directory on the server. Then it seemed to have trouble
with two other files. I moved them out of the server's
imap directory but they still manage to show up in my
mozilla ImapMail directory even after I deleted ~/.mozilla
and started over. Mozilla gets to a point where its looking
for folders and then freezes.

--------
client machine:
Linux #1 SMP Mon Sep 27 10:34:45 EDT 1999


-----------------------------------
cannibal[62] %/usr/sbin/imapd -v
* PREAUTH cannibal.mi.org IMAP4rev1 v10.234 server ready


------------
[endico@localhost ImapMail]$ pwd
/home/endico/.mozilla/mozProfile/ImapMail
[endico@localhost ImapMail]$ ls -lR
.:
total 4
drwx------   3 endico   endico       4096 Jan  9 18:55 server1

server1:
total 12
-rw-rw-r--   1 endico   endico       1008 Jan  9 18:54 INBOX.msf
-rw-rw-r--   1 endico   endico       1007 Jan  9 18:55 mail.msf
drwx------   2 endico   endico       4096 Jan  9 18:55 mail.sbd

server1/mail.sbd:
total 32
-rw-rw-r--   1 endico   endico       1008 Jan  9 18:55 Trash.msf
-rw-rw-r--   1 endico   endico       1008 Jan  9 18:55 dacoo.msf
-rw-rw-r--   1 endico   endico       1008 Jan  9 18:55 grope.msf
-rw-rw-r--   1 endico   endico       1006 Jan  9 18:55 lxr.msf
-rw-rw-r--   1 endico   endico       1010 Jan  9 18:55 mozilla.msf
-rw-rw-r--   1 endico   endico       1012 Jan  9 18:55 openscape.msf
-rw-rw-r--   1 endico   endico       1012 Jan  9 18:55 sent-mail.msf
-rw-rw-r--   1 endico   endico       1007 Jan  9 18:55 test.msf

WEBSHELL- = 8
nsWidget::~nsWidget() of toplevel: 42 widgets still exist.
WEBSHELL- = 7
[Switching to Thread 15291]


Program received signal SIGTSTP, Stopped (user).
0x402e358b in ?? () from /lib/libc.so.6
(gdb) where
#0  0x402e358b in ?? () from /lib/libc.so.6
#1  0x4022e1a0 in pthread_cond_wait (cond=0x8301bbc, mutex=0x82b3bb4)
    at restart.h:49
#2  0x4020bf98 in ?? () from /home/endico/mozilla/mozilla/dist/bin/libnspr3.so
#3  0x4020c797 in ?? () from /home/endico/mozilla/mozilla/dist/bin/libnspr3.so
#4  0x401d954e in ?? () from /home/endico/mozilla/mozilla/dist/bin/libplds3.so
#5  0x4016fe29 in ?? () from /home/endico/mozilla/mozilla/dist/bin/libxpcom.so
#6  0x4017422d in ?? () from /home/endico/mozilla/mozilla/dist/bin/libxpcom.so
#7  0x40174640 in ?? () from /home/endico/mozilla/mozilla/dist/bin/libxpcom.so
#8  0x401768f7 in ?? () from /home/endico/mozilla/mozilla/dist/bin/libxpcom.so
#9  0x40181ad4 in ?? () from /home/endico/mozilla/mozilla/dist/bin/libxpcom.so
#10 0x40181bae in ?? () from /home/endico/mozilla/mozilla/dist/bin/libxpcom.so
#11 0x41677b6a in ?? ()
   from /home/endico/mozilla/mozilla/dist/bin/components/libmsgimap.so
#12 0x41688104 in ?? ()
   from /home/endico/mozilla/mozilla/dist/bin/components/libmsgimap.so
#13 0x41687d10 in ?? ()
   from /home/endico/mozilla/mozilla/dist/bin/components/libmsgimap.so
#14 0x41687a1c in ?? ()
   from /home/endico/mozilla/mozilla/dist/bin/components/libmsgimap.so
#15 0x4168731d in ?? ()
   from /home/endico/mozilla/mozilla/dist/bin/components/libmsgimap.so
#16 0x416865e2 in ?? ()
   from /home/endico/mozilla/mozilla/dist/bin/components/libmsgimap.so
#17 0x4167015d in ?? ()
   from /home/endico/mozilla/mozilla/dist/bin/components/libmsgimap.so
#18 0x4167d34c in ?? ()
   from /home/endico/mozilla/mozilla/dist/bin/components/libmsgimap.so
#19 0x4167c69c in ?? ()
   from /home/endico/mozilla/mozilla/dist/bin/components/libmsgimap.so
#20 0x4167c1f0 in ?? ()
   from /home/endico/mozilla/mozilla/dist/bin/components/libmsgimap.so
#21 0x4166fa89 in ?? ()
   from /home/endico/mozilla/mozilla/dist/bin/components/libmsgimap.so
#22 0x4166f679 in ?? ()
   from /home/endico/mozilla/mozilla/dist/bin/components/libmsgimap.so
#23 0x4166ecea in ?? ()
   from /home/endico/mozilla/mozilla/dist/bin/components/libmsgimap.so
#24 0x40171865 in ?? () from /home/endico/mozilla/mozilla/dist/bin/libxpcom.so
#25 0x402148fb in ?? () from /home/endico/mozilla/mozilla/dist/bin/libnspr3.so
#26 0x4022eeca in pthread_start_thread (arg=0xbf3ffe60) at manager.c:213
(gdb) shar libnspr
Reading symbols from /home/endico/mozilla/mozilla/dist/bin/libnspr3.so...done.
(gdb) shar libxpcom
Reading symbols from /home/endico/mozilla/mozilla/dist/bin/libxpcom.so...done.
(gdb) shar libmsgimap
Reading symbols from
/home/endico/mozilla/mozilla/dist/bin/components/libmsgimap.so...done.
(gdb) where
#0  0x402e358b in ?? () from /lib/libc.so.6
#1  0x4022e1a0 in pthread_cond_wait (cond=0x8301bbc, mutex=0x82b3bb4)
    at restart.h:49
#2  0x4020bf98 in PR_WaitCondVar (cvar=0x8301bb8, timeout=4294967295)
    at ptsynch.c:360
#3  0x4020c797 in PR_Wait (mon=0x82b3bb0, timeout=4294967295) at ptsynch.c:545
#4  0x401d954e in ?? () from /home/endico/mozilla/mozilla/dist/bin/libplds3.so
#5  0x4016fe29 in nsEventQueueImpl::WaitForEvent (this=0x82f5550,
    aResult=0xbf3ff5f4) at nsEventQueue.cpp:282
#6  0x4017422d in nsProxyObject::PostAndWait (this=0x419af4a8,
    proxyInfo=0x8285a58) at nsProxyEvent.cpp:296
#7  0x40174640 in nsProxyObject::Post (this=0x419af4a8, methodIndex=3,
    methodInfo=0x819ec58, params=0xbf3ff72c, interfaceInfo=0x41db2d80)
    at nsProxyEvent.cpp:406
#8  0x401768f7 in nsProxyEventObject::CallMethod (this=0x419af3f0,
    methodIndex=3, info=0x819ec58, params=0xbf3ff72c)
    at nsProxyEventObject.cpp:391
#9  0x40181ad4 in PrepareAndDispatch (self=0x419af3f0, methodIndex=3,
    args=0xbf3ff7e4) at xptcstubs_unixish_x86.cpp:92
#10 0x40181bae in nsXPTCStubBase::Stub3 (this=0x419af3f0)
    at ../../../../../../dist/include/xptcstubsdef.inc:5
#11 0x41677b6a in nsImapProtocol::DiscoverMailboxSpec (this=0x41db2fe0,
    adoptedBoxSpec=0x82c4e90) at nsImapProtocol.cpp:3828
#12 0x41688104 in nsImapServerResponseParser::mailbox (this=0x41db30bc,
    boxSpec=0x82c4e90) at nsImapServerResponseParser.cpp:890
#13 0x41687d10 in nsImapServerResponseParser::mailbox_list (this=0x41db30bc,
    discoveredFromLsub=1) at nsImapServerResponseParser.cpp:796
#14 0x41687a1c in nsImapServerResponseParser::mailbox_data (this=0x41db30bc)
    at nsImapServerResponseParser.cpp:725
#15 0x4168731d in nsImapServerResponseParser::response_data (this=0x41db30bc)
    at nsImapServerResponseParser.cpp:530
#16 0x416865e2 in nsImapServerResponseParser::ParseIMAPServerResponse (
    this=0x41db30bc, currentCommand=0x82adb68 "4 lsub \"\" \"*\"\r\n")
    at nsImapServerResponseParser.cpp:205
#17 0x4167015d in nsImapProtocol::ParseIMAPandCheckForNewMail (
    this=0x41db2fe0, commandString=0x0) at nsImapProtocol.cpp:1159
#18 0x4167d34c in nsImapProtocol::Lsub (this=0x41db2fe0,
    mailboxPattern=0x836dba0 "*", addDirectoryIfNecessary=1)
    at nsImapProtocol.cpp:5635
#19 0x4167c69c in nsImapProtocol::DiscoverMailboxList (this=0x41db2fe0)
    at nsImapProtocol.cpp:5381
#20 0x4167c1f0 in nsImapProtocol::FindMailboxesIfNecessary (this=0x41db2fe0)
    at nsImapProtocol.cpp:5263
#21 0x4166fa89 in nsImapProtocol::ProcessCurrentURL (this=0x41db2fe0)
    at nsImapProtocol.cpp:1068
#22 0x4166f679 in nsImapProtocol::ImapThreadMainLoop (this=0x41db2fe0)
    at nsImapProtocol.cpp:892
#23 0x4166ecea in nsImapProtocol::Run (this=0x41db2fe0)
    at nsImapProtocol.cpp:674
#24 0x40171865 in nsThread::Main (arg=0x41f11940) at nsThread.cpp:83
#25 0x402148fb in _pt_root (arg=0x41f11958) at ptthread.c:157
#26 0x4022eeca in pthread_start_thread (arg=0xbf3ffe60) at manager.c:213
(gdb) up
#1  0x4022e1a0 in pthread_cond_wait (cond=0x8301bbc, mutex=0x82b3bb4)
    at restart.h:49
49	restart.h: No such file or directory.
Current language:  auto; currently c
(gdb) print
The history is empty.
(gdb) list
44	in restart.h
(gdb) up
#2  0x4020bf98 in PR_WaitCondVar (cvar=0x8301bb8, timeout=4294967295)
    at ptsynch.c:360
360	        rv = pthread_cond_wait(&cvar->cv, &cvar->lock->mutex);

(gdb) list
355	     * We're surrendering the lock, so clear out the owner field.
356	     */
357	    _PT_PTHREAD_ZERO_THR_HANDLE(cvar->lock->owner);
358
359	    if (timeout == PR_INTERVAL_NO_TIMEOUT)
360	        rv = pthread_cond_wait(&cvar->cv, &cvar->lock->mutex);
361	    else
362	        rv = pt_TimedWait(&cvar->cv, &cvar->lock->mutex, timeout);
363
364	    /* We just got the lock back - this better be empty */
(gdb)
365	    PR_ASSERT(_PT_PTHREAD_THR_HANDLE_IS_ZERO(cvar->lock->owner));
366	    _PT_PTHREAD_COPY_THR_HANDLE(pthread_self(), cvar->lock->owner);
367
368	    PR_ASSERT(0 == cvar->lock->notified.length);
369	    thred->waiting = NULL;  /* and now we're not */
370	    if (_PT_THREAD_INTERRUPTED(thred)) goto aborted;
371	    return (rv == 0) ? PR_SUCCESS : PR_FAILURE;
372
373	aborted:
374	    PR_SetError(PR_PENDING_INTERRUPT_ERROR, 0);
(Assignee)

Comment 1

18 years ago
adding david b to the cc list. David, can you tell from this log output what
type of IMAP server Dawn's using that's giving her this problem?
PREAUTH cannibal.mi.org IMAP4rev1 v10.234 server ready

Comment 2

18 years ago
looks like a UW server to me. Turning on Imap client protocol logging would be
helpful. I'll try to fill in the instructions for that later

it's something like
setenv NSPR_LOG_MODULES IMAP:5
setenv NSPR_LOG_FILE /tmp/imapio.txt
(Assignee)

Comment 3

18 years ago
I'm pretty sure this is a duplicate of 23312....
(Reporter)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

18 years ago
*** This bug has been marked as a duplicate of 23312 ***
(Reporter)

Comment 5

18 years ago
Mozilla works after removing the trailing slash from my .mailboxlist file
on the server.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 6

18 years ago
verifying as duplicate
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.