Installer crashes before finishing

VERIFIED FIXED

Status

()

--
critical
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: bugzilla, Assigned: mscott)

Tracking

({crash, regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2004-02-19-08-trunk/FirefoxSetup.exe

When installing this build into a new clean directory, the installer crashes
near the end of the installation, just before installing the default
language/language pack information.

WinXP reports it as a problem with xpinstal.dll.

I have also replicated this crash on a Win2000 system.

If you do this install on top of an existing installation, no crash occurs.

Reproducible: Always
Steps to Reproduce:
(Reporter)

Updated

15 years ago
Keywords: crash

Comment 1

15 years ago
Created attachment 141828 [details]
Mozilla Firebird Install Status Log

Install Status from crashed Mozilla Firefox Installer

Updated

15 years ago
Attachment #141828 - Attachment description: Mozilla Firebird Install Status → Mozilla Firebird Install Status Log

Comment 2

15 years ago
Created attachment 141829 [details]
Mozilla Firefox Install Wizard Log

Comment 3

15 years ago
Attached are the installer logs from my crash.  The last message on the
installer dialog is the US English Defaults.
(Reporter)

Comment 4

15 years ago
This may turn out to be a dup of bug 234804.
(Reporter)

Comment 5

15 years ago
Making this (tentatively) dependent on 234804.
Depends on: 234804

Comment 6

15 years ago
(In reply to comment #3)
> Attached are the installer logs from my crash.  The last message on the
> installer dialog is the US English Defaults.

I just tried to install build 2004-02-20-08 on WinXP Home, and I got the same
results.

Joseph 

Updated

15 years ago
Keywords: regression
(Reporter)

Comment 7

15 years ago
*** Bug 235103 has been marked as a duplicate of this bug. ***
*** Bug 235128 has been marked as a duplicate of this bug. ***
I'm seeing this with seamonkey nightly as well.  I'm going to attach wizard and
install log now.

Could this block 1.7a?  Or has a candidate already been chosen? (I'm out of
touch on the SeaMonkey release schedule).
Created attachment 141901 [details]
Seamonkey - Wizard Log
Created attachment 141902 [details]
Seamonkey -Status Log
(Reporter)

Comment 12

15 years ago
There is already a Seamonkey bug on this, 234804.

This bug is dependent on the Seamonkey bug (for now).  It may be that this bug
will turn out to be a dup of that one.
(Assignee)

Comment 13

15 years ago
For details about the cause of this crash, see my comments:

http://bugzilla.mozilla.org/show_bug.cgi?id=234804#c39

I've stepped through the crash in the debugger. For this deflenus.xpi package
ONLY we end up using UNIX style path delimiters instead of windows style path
delimiters. This is what causes the crash.
(Assignee)

Comment 14

15 years ago
I found a fix for this
Assignee: bugs → mscott
(Assignee)

Updated

15 years ago
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Updated

15 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.