Images displayed as broken

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: rkade, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a) Gecko/20040219 Firefox/0.8.0+

firefox wont display many of images even with reloading. you can use the view
option in right click to view broken images then the back button and it will
load that one image only. Also on this page
http://fileforum.betanews.com/detail.php3?fid=1028299275
the image of url http://fileforum.betanews.com/screenshots/1028299275.jpg
shows up as broken. Both these pages load fine using netscape 7.02
(Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.2) Gecko/20030208 Netscape/7.02)
which is my current everyday browser.  

Reproducible: Always
Steps to Reproduce:
1.used bookmarks to go to pages which didn't load images, tried reloading with
no luck
2.tried viewing images on iexbeta... most would load after using back function
on the betanews page I could get the large jpg to load by clicking on it or
viewing taking it to a seperate or next page but going back/reloading original
page still showed broken image.
3.tried same pages using my netscape 7.02 browser, which I have been visiting
both sites for over a year with no problems... both come up with no images
missing on it using same internet connection at same login session.



Expected Results:  
software should have loaded iexbeta site images properly and
should have loaded the image (large) at a smaller size like many
of the screenshots on the betanews sites load.

Comment 1

14 years ago
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040218
Firefox/0.8.0+
1) Do you have any sites listed under the Images sectin of Tools->Options-Web
Features?
2) What are your current settings for allow images/allow from originating site only

All sites listed work for me under Linux
QA Contact: mconnor

Comment 3

14 years ago
Some jpg images not loading. Cannot load image in HTML page nor as direct link
to image. Firefox reports it as file not found. Image will load in Mozilla and IE 5+

http://carriemcqueen.com/images/review1.jpg

is exmple of an image that displays this problem.

Comment 4

14 years ago
(In reply to comment #3)
> http://carriemcqueen.com/images/review1.jpg

This image works for me.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

Comment 5

14 years ago
when an underscore is used in the path an image or link seems to be invalid.
Is there any setting or workaround to change this?

Comment 6

14 years ago
(In reply to comment #0)
> User-Agent:       
> Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a)
Gecko/20040219 Firefox/0.8.0+
> 
> firefox wont display many of images even with reloading. you can use the view
> option in right click to view broken images then the back button and it will
> load that one image only. Also on this page
> http://fileforum.betanews.com/detail.php3?fid=1028299275
> the image of url http://fileforum.betanews.com/screenshots/1028299275.jpg
> shows up as broken. Both these pages load fine using netscape 7.02
> (Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.2) Gecko/20030208 Netscape/7.02)
> which is my current everyday browser.  
> 
> Reproducible: Always
> Steps to Reproduce:
> 1.used bookmarks to go to pages which didn't load images, tried reloading with
> no luck
> 2.tried viewing images on iexbeta... most would load after using back function
> on the betanews page I could get the large jpg to load by clicking on it or
> viewing taking it to a seperate or next page but going back/reloading original
> page still showed broken image.
> 3.tried same pages using my netscape 7.02 browser, which I have been visiting
> both sites for over a year with no problems... both come up with no images
> missing on it using same internet connection at same login session.
> 
> 
> 
> Expected Results:  
> software should have loaded iexbeta site images properly and
> should have loaded the image (large) at a smaller size like many
> of the screenshots on the betanews sites load.

I have the same exact problem.  About half of all the web pages I vist have
problems loading some or most of the images on the page.  If I right click and
select view image it appears on its own page and then when I go back only that
image is loaded.  I do have load images selected in the options, I am running 
Windows XP with firefox 0.9.2.  This bug forces me to run IE even though I don't
want to.  I really hope they fix this bug because it is a hinderence to me using
what I once thought was a great browser.
Ethan, can you check whether "for the originating site only" is also checked? 
That's the cause of that type of symptom 99% of the time.

Comment 8

13 years ago
(In reply to comment #7)
> Ethan, can you check whether "for the originating site only" is also checked? 
> That's the cause of that type of symptom 99% of the time.

Where do we find that setting?

Comment 9

13 years ago
(In reply to comment #7)
> Ethan, can you check whether "for the originating site only" is also checked? 
> That's the cause of that type of symptom 99% of the time.

Where do we find that setting?
(In reply to comment #9)
> Where do we find that setting?

Tools -> Options -> Web Features
Bottom of the dialog.

Comment 11

13 years ago
I have a similar problem. When I open my wish list on www.amazon.com, I cannt
see some images of the product on the list. I tried all the options in
Tools->Options.
Fortunately, some times Firefox shows all images on the list but not dependin on
the options.

Comment 12

13 years ago
Also have this problem consistently with 

http://www.beardsworth.co.uk/gallery.php?group=Italy

and

http://www.phonebin.co.uk

Load images is set, only from originating server is unchecked.

When reloading the page, some images are then lost while others that didn't
display are loaded, in other words, image loading is random.

sites work fine in IE6

Z

WinXP Pro, SP2 (XP firewall off), ZAPro (tried it switched off), Firefox
Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

Comment 13

13 years ago
lots of JPG's are NOT being shown, and when you right click to load that image
it reports it as a BAD or BROKEN jpg. IE displays it ok.

right now it's happening at  www.tomshardware.com  on most reviews found there

http://www6.tomshardware.com/motherboard/20041111/xeon-15.html

this review  does not show SOME pictures while the rest are ok. I'm using JAVA
1.5 and Zonaalrm 5.5 is NOT set to kill web bugs or images
#13 - WFM FireFox 1.0 and yesterday's nightly build (Mozilla/5.0 (Windows; U;
Win98; en-US; rv:1.8b2) Gecko/20050329 Firefox/1.0+)

Please update to the most recent version fo Firefox (1.2.0) to correct this
problem. If there is still a problem with images on Windows 98 (which is what
this report is for) I will investigate them. If there are no other problems,
then after 30 days I will mark this bug "FIXED."
> Also have this problem consistently with 
> 
> http://www.beardsworth.co.uk/gallery.php?group=Italy
> 
> and
> 
> http://www.phonebin.co.uk
> 
> Load images is set, only from originating server is unchecked.
> 
> When reloading the page, some images are then lost while others that didn't
> display are loaded, in other words, image loading is random.
> 
> sites work fine in IE6
> 
> Z
> 
> WinXP Pro, SP2 (XP firewall off), ZAPro (tried it switched off), Firefox
> Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

zilpher - Please update to the newest version of Firefox (1.2.0) available on
the main website.

If you continue to have problems please search for a bug report that adresses
this issue in Windows XP and if you do not find one, please submit one. Bugs
that are cross-platform (multiple Operating systems) start out as bugs on
seperate platforms and are put together by us.

Thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 16

13 years ago
I have this same issue using Firefox 1.0.4. I have identified that it only
happens on images using the underscore character - any other normally valid
character works. This URL works fine on IE, but when entered in to firefox 1.0.4
I get an error:

URL: http://www.giannasgems.com/SCPM3/Images/LH2-05_CORO.jpg

ERROR: /SCPM3/Images/LH2-05_CORO.jpg could not be found.

I'm not sure why the error message does not include the full URL?
You need to log in before you can comment on or make changes to this bug.