Crash in gklayout.dll at this site (intermittent) [@ nsHTMLReflowState::Init ]

RESOLVED DUPLICATE of bug 243528

Status

()

--
critical
RESOLVED DUPLICATE of bug 243528
15 years ago
8 years ago

People

(Reporter: errol, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-GB; rv:1.7a) Gecko/20040217

This site will _sometimes_ crash mozilla with a pagefault. I've seen this with
1.6 as well as this build (20040217) on 98se. Crash happens not only on the main
page (supplied URL) but also other pages within the site.
Crash appears happens to happen during page load.

Reproducible: Sometimes
Steps to Reproduce:
1. go to http://www.nswlotteries.com.au/
2. browse around the site (click on the different lotteries down the left and
their sub menus down the right)


Actual Results:  
Browser pagefaults sometimes

Expected Results:  
No crash

Two separate incidents follow. I will try to reproduce this with a talkback when
I get 1.7a final.

MOZILLA caused an invalid page fault in
module GKLAYOUT.DLL at 016f:01136ff0.
Registers:
EAX=00000000 CS=016f EIP=01136ff0 EFLGS=00010246
EBX=0240f538 SS=0177 ESP=00668f00 EBP=00668f08
ECX=00668f58 DS=0177 ESI=00668f58 FS=43cf
EDX=00000000 ES=0177 EDI=00669120 GS=0000
Bytes at CS:EIP:
8b 48 18 e8 33 4d 0a 00 89 86 90 00 00 00 8b 46 
Stack dump:
00000004 00668f58 00668f2c 01136d66 03dc3bf0 ffffffff ffffffff 00000000 00000000
00669120 006691d8 006690c4 011711fb 03dc3bf0 00669120 00000000 

MOZILLA caused an invalid page fault in
module GKLAYOUT.DLL at 016f:01136ff0.
Registers:
EAX=00000000 CS=016f EIP=01136ff0 EFLGS=00010246
EBX=03181498 SS=0177 ESP=006690b4 EBP=006690bc
ECX=0066910c DS=0177 ESI=0066910c FS=2dff
EDX=00000000 ES=0177 EDI=006692d4 GS=0000
Bytes at CS:EIP:
8b 48 18 e8 33 4d 0a 00 89 86 90 00 00 00 8b 46 
Stack dump:
00000004 0066910c 006690e0 01136d66 034fb650 ffffffff ffffffff 00000000 00000000
006692d4 0066938c 00669278 011711fb 034fb650 006692d4 00000000

Comment 1

15 years ago
I can't seem to reproduce this with my own Moz build from 20040119 and firebird
from 20040129 no matter how long I click around. How long did you surf around
before it crashed? Does clearing your cache/profile help?

Comment 2

15 years ago
WFM 2004021810/trunk/W2K
-> Layout
Assignee: general → nobody
Component: Browser-General → Layout
Keywords: crash
QA Contact: general → core.layout
(Reporter)

Comment 3

15 years ago
OK I got it to crash with the 1.7a prerelease talkback build - talkback ID is
TB30569728W  22/02/2004 9:59PM (eastern Australia summer time btw).
(Mozilla/5.0 (Windows; U; Win98; en-GB; rv:1.7a) Gecko/20040219)

re comment #1 - it depends, sometimes it would crash the first time I loaded the
page, other times I could look through the site for 20mins without a crash. I've
cleared cache & bookmarks recently but that didn't make a difference. I'll try
to get it to go again with a new profile & see if that helps.

Sorry if slow to respond, I think my ISP is spam filtering bugmail.. :-/

Comment 4

15 years ago
Marking NEW since you have a talkback ID now. I'll try to reproduce it later
when I'm at home.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

15 years ago
I put this here as it seems related.. My browser crashes on different sites
seemingly at random.  It can occur just after pageload, while opening or looking
at preferences. or just while moving my mouse across the screen.

There are only a couple of things to point at as far as a pattern..1.sometimes
the crash occurs slightly after an hourglass appears.. 2. about 1 in 4 times it
has a cuclical pattern of crash(while browsing), restart->crash(during splash
screen), restart->crash(just after browser window pops up but before any
pageloading), restart->normal operation.  

Modules can vary, most often being gklayout.dll, sometimes js3250.dll, and
occasionally module<unknown>.  If it gets very bad and is crashing constantly
sometimes it wil ome out with other ones like xpcom.dll but thats usually a sign
it has destabalized my system.

I have win98se on amd cpu, via chipset, geforce2-mx400 graphics card.  I have
tried many versions of graphics card drivers, currently I have the most modern.
each after fresh windows installs. I have also tried going back to a previous
image of my hardrive.  Ive tried mozilla 1.4-1.7 and all seem to have this
problem to varying degrees.  Rebooting seems to have no effect, nor does
deleting profiles, reinstalling windows, mozilla, or drivers.

I was getting very frustrated the other nite, and copied the info from the crash
dialogue, as talkbalk dosnt seem to be working.  Ill paste those below.. sorry
for the length but I wanted to get a good sample.  This is from about a 15
minute stretch of time:
MOZILLA caused an invalid page fault in
module <unknown> at 0000:20b38573.
Registers:
EAX=00000001 CS=016f EIP=20b38573 EFLGS=00010202
EBX=01da4a90 SS=0177 ESP=0066f0b4 EBP=007ee020
ECX=0066f0cc DS=0177 ESI=01da49f0 FS=2887
EDX=81d1b5fc ES=0177 EDI=01da4a08 GS=0000
Bytes at CS:EIP:


MOZILLA caused an invalid page fault in
module JS3250.DLL at 016f:00b3adc5.
Registers:
EAX=00000000 CS=016f EIP=00b3adc5 EFLGS=00010287
EBX=20000009 SS=0177 ESP=0066fa2c EBP=0066fa38
ECX=00000001 DS=0177 ESI=023a08d0 FS=37af
EDX=01d6d9e0 ES=0177 EDI=023a0750 GS=0000
Bytes at CS:EIP:
f6 40 10 04 75 0f ff 75 10 50 ff 75 08 e8 7a ef 
Stack dump:
01d40498 023a08d0 023a0a90 0066fa50 00b18878 023741a0 00000009 00000000 00000000
0066fa70 00b29f86 023741a0 01d40498 00000000 023a1a4c 023a0bb4 


MOZILLA caused an invalid page fault in
module JS3250.DLL at 016f:00b2813b.
Registers:
EAX=025f4900 CS=016f EIP=00b2813b EFLGS=00010206
EBX=01d36c80 SS=0177 ESP=0066e2c4 EBP=0066e2f0
ECX=0066e324 DS=0177 ESI=007efd90 FS=1b2f
EDX=00000000 ES=0177 EDI=21d32de8 GS=0000
Bytes at CS:EIP:
8b 07 8b 40 04 3d 28 c6 b4 00 74 0e 85 c0 74 4d 
Stack dump:
0080a650 0076c460 01d36c80 01d36c80 0080a630 00000001 01d36c80 025ff180 011c5b73
025f4900 00000000 0066e328 00b284c8 00000001 01d36c80 0080a630 

MOZILLA caused an invalid page fault in
module <unknown> at 0000:20b38573.
Registers:
EAX=00000001 CS=016f EIP=20b38573 EFLGS=00010202
EBX=01dda420 SS=0177 ESP=0066e310 EBP=007efd90
ECX=0066e328 DS=0177 ESI=01dda380 FS=0e3f
EDX=81d1b5fc ES=0177 EDI=01dda3c8 GS=0000
Bytes at CS:EIP:

Stack dump:
0000001e 01dda380 01dda380 0066e360 007efd90 00b10000 01dda67a 00000000 3ff00000
007efd90 025b31c0 02524450 025b0660 025363c0 00b306c2 007efd90 

MOZILLA caused an invalid page fault in
module GKLAYOUT.DLL at 016f:00fecd08.
Registers:
EAX=00000000 CS=016f EIP=00fecd08 EFLGS=00010202
EBX=01ff1efc SS=0177 ESP=0066ed74 EBP=0066ee30
ECX=01f5b8c4 DS=0177 ESI=00000002 FS=0e37
EDX=21f5bbf8 ES=0177 EDI=026625b0 GS=0000
Bytes at CS:EIP:
8b 04 02 85 c0 75 0c 6a 01 51 8b 49 18 56 e8 47 
Stack dump:
01f5b8c4 00f68edb 00000002 01f5b700 00f6834c 01ede6c8 00000001 00000000 01f5b84c
01ff1efc 00000002 00000000 00000002 00001752 00000a32 00000cd5 

MOZILLA caused an invalid page fault in
module GKLAYOUT.DLL at 016f:00f41db6.
Registers:
EAX=210fd068 CS=016f EIP=00f41db6 EFLGS=00010246
EBX=01f968e4 SS=0177 ESP=0066ef58 EBP=0066ef9c
ECX=0066ef8c DS=0177 ESI=00a6a4d0 FS=0f3f
EDX=00000000 ES=0177 EDI=0066ef8c GS=0000
Bytes at CS:EIP:
ff 50 54 8b 45 10 d9 45 14 80 48 18 01 d9 58 10 
Stack dump:
01f968e4 02612010 00a6a4d0 0066ef8c 00000000 00000000 01f673cc 01f968e4 00000000
00000726 00000000 00000078 0000289b 00000000 00000000 00000078 

MOZILLA caused an invalid page fault in
module <unknown> at 0000:0001a364.
Registers:
EAX=00000000 CS=016f EIP=0001a364 EFLGS=00010246
EBX=00000000 SS=0177 ESP=0066e7c8 EBP=0066e818
ECX=0066e7a4 DS=0177 ESI=10041262 FS=1b67
EDX=0066e778 ES=0177 EDI=80000000 GS=0000
Bytes at CS:EIP:
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 
Stack dump:
0186239e 00000060 10041262 01e285d0 00000000 10044b38 0187b5dc 00000000 0066e80c
0079e040 00000001 00000001 00000000 0079e3f0 0079e040 00000000 

MOZILLA caused an invalid page fault in
module JS3250.DLL at 016f:00b38eaa.
Registers:
EAX=01eff8e4 CS=016f EIP=00b38eaa EFLGS=00010206
EBX=00000016 SS=0177 ESP=0066e0bc EBP=0066e0d8
ECX=00819950 DS=0177 ESI=e80163b6 FS=3777
EDX=000003a0 ES=0177 EDI=21ec1518 GS=0000
Bytes at CS:EIP:
39 0f 0f 84 95 00 00 00 6a 20 5f 2b fb 8b cf d3 
Stack dump:
01ed5488 00a76d90 00a7e110 00000001 21ec1518 21ec1519 00000000 0066e118 00b27e5a
00a7e110 00819950 00000000 000003ff 0069ac48 01ed5488 01edfe78 

MOZILLA caused an invalid page fault in
module <unknown> at 0000:219624d0.
Registers:
EAX=007bcbe0 CS=016f EIP=219624d0 EFLGS=00010202
EBX=10041294 SS=0177 ESP=0066eabc EBP=0066ebc8
ECX=0196b8e0 DS=0177 ESI=10041262 FS=2c5f
EDX=00000075 ES=0177 EDI=00000000 GS=0000
Bytes at CS:EIP:

Stack dump:
01961982 007bcbe0 80000000 0235b770 00000000 80000000 007adcc0 0066eb60 0066eaf4
00eaf9a5 0066eae8 0066eb60 1003f839 0066eb64 1003e2ee 0066eb64 

OZILLA caused an invalid page fault in
module JS3250.DLL at 016f:00b3adc5.
Registers:
EAX=22358830 CS=016f EIP=00b3adc5 EFLGS=00010297
EBX=00000002 SS=0177 ESP=0066c260 EBP=0066c26c
ECX=01d27f38 DS=0177 ESI=023588b0 FS=0f57
EDX=00b4c628 ES=0177 EDI=0235b8e0 GS=0000
Bytes at CS:EIP:
f6 40 10 04 75 0f ff 75 10 50 ff 75 08 e8 7a ef 
Stack dump:
01d27f38 00000000 008629c0 0066c29c 00b3a8f1 007efd90 00000001 00000000 00b29f86
007efd90 01d27f38 00000000 01e3efd0 0086c9c4 01e3ef04 0066c2b8 

MOZILLA caused an invalid page fault in
module JSDOM.DLL at 016f:01ae44e3.
Registers:
EAX=100446b0 CS=016f EIP=01ae44e3 EFLGS=00010286
EBX=21af482c SS=0177 ESP=0066ede8 EBP=0066ee88
ECX=0079f664 DS=0177 ESI=10041262 FS=36ff
EDX=86000009 ES=0177 EDI=80000000 GS=0000
Bytes at CS:EIP:
83 3b 00 75 25 8b 43 04 3b 05 4c 26 af 01 75 1a 
Stack dump:
10041262 00000000 80000000 01e490e0 0066ee20 00fecb44 025dd140 01e48bd0 025de9b0
00fed551 00000000 00000000 01e48bd0 025dd140 0066ee4c 01e48bd0 

MOZILLA caused an invalid page fault in
module XPCOM.DLL at 016f:1000e670.
Registers:
EAX=211118b0 CS=016f EIP=1000e670 EFLGS=00010282
EBX=01ea5cdc SS=0177 ESP=0066f0e8 EBP=0066f114
ECX=00684fac DS=0177 ESI=10064e9c FS=379f
EDX=00000000 ES=0177 EDI=00684fac GS=0000
Bytes at CS:EIP:
8b 00 c3 24 fe 83 c0 08 c3 8b 4c 24 08 e8 e2 ff 
Stack dump:
10010481 10064e9c 00684fac 9351b692 00000001 00000800 10064e9c bf675a0c 00684e44
00000008 1000ff5a 0066f130 1001026b 000007d3 1000e65b 023412d4 

MOZILLA caused an invalid page fault in
module <unknown> at 0000:219624d0.
Registers:
EAX=007bcbe0 CS=016f EIP=219624d0 EFLGS=00010202
EBX=00000000 SS=0177 ESP=0066edac EBP=0066ede0
ECX=0196b8e0 DS=0177 ESI=80000000 FS=2ad7
EDX=40fda04b ES=0177 EDI=10041294 GS=0000
Bytes at CS:EIP:

Stack dump:
01961831 007bcbe0 007ab090 80000000 007e4030 10044b18 10043e78 007e6744 0066eddc
007e6744 007e6740 007bcbe0 00000000 0066ee5c 00ea73b7 007e2040 

MOZILLA caused an invalid page fault in
module JS3250.DLL at 016f:00b19899.
Registers:
EAX=0000004f CS=016f EIP=00b19899 EFLGS=00010202
EBX=024e89b0 SS=0177 ESP=0066f9d0 EBP=0066f9e0
ECX=2076cc00 DS=0177 ESI=022f98e4 FS=248f
EDX=2076ce78 ES=0177 EDI=022f98f8 GS=0000
Bytes at CS:EIP:
03 41 04 3b 01 72 05 05 00 20 00 00 c3 ff 74 24 
Stack dump:
00b19d95 2076ce78 022f98f8 022f98e4 0066f9fc 00b19e11 023741a0 2076ce78 00000000
022f97d8 022f97d0 0066fa18 00b19e11 023741a0 01d23c08 00000000 

MOZILLA caused an invalid page fault in
module GKLAYOUT.DLL at 016f:00fb7b51.
Registers:
EAX=20a4d370 CS=016f EIP=00fb7b51 EFLGS=00010202
EBX=01f6f8d8 SS=0177 ESP=0066f31c EBP=0066f340
ECX=00000000 DS=0177 ESI=01f6f8d8 FS=2b17
EDX=0000000b ES=0177 EDI=00000800 GS=0000
Bytes at CS:EIP:
8b 08 50 ff 51 10 8b 55 08 ff 75 14 8b 45 fc 8b 
Stack dump:
0066f35c 01f6f8d8 01f6f8d8 01136f44 00000000 01f6f8d8 00000000 00000000 00000000
0066f3d8 00fb753a 0000000b 01f702f0 0066f35c 0066f39c 0000000b 

MOZILLA caused an invalid page fault in
module IMGLIB2.DLL at 016f:01865825.
Registers:
EAX=45dbfffa CS=016f EIP=01865825 EFLGS=00010206
EBX=02678f74 SS=0177 ESP=0066fbd4 EBP=0066fc14
ECX=0066fc0c DS=0177 ESI=00000004 FS=2a17
EDX=00000004 ES=0177 EDI=01010000 GS=0000
Bytes at CS:EIP:
ff 50 64 83 7d f8 00 7e 0e 8b 43 48 ff 75 f8 8b 
Stack dump:
01010000 0066fc0c 025dd090 025dd090 0223bad0 0066fc08 1002beee 03f65d53 025dd090
10044b98 0267c290 00000000 00000003 0066fc84 00000000 

MOZILLA caused an invalid page fault in
module IMGLIB2.DLL at 016f:01865825.
Registers:
EAX=45dbfffa CS=016f EIP=01865825 EFLGS=00010206
EBX=02678f74 SS=0177 ESP=0066fbd4 EBP=0066fc14
ECX=0066fc0c DS=0177 ESI=00000004 FS=2a17
EDX=00000004 ES=0177 EDI=01010000 GS=0000
Bytes at CS:EIP:
ff 50 64 83 7d f8 00 7e 0e 8b 43 48 ff 75 f8 8b 
Stack dump:
01010000 0066fc0c 025dd090 025dd090 0223bad0 0066fc08 1002beee 03f65d53 025dd090
10044b98 0267c290 00000000 00000003 0066fc84 00000000 

MOZILLA caused an invalid page fault in
module <unknown> at 0000:20ed1cf5.
Registers:
EAX=00a1ae90 CS=016f EIP=20ed1cf5 EFLGS=00010246
EBX=00000000 SS=0177 ESP=0066f9e0 EBP=0066fa18
ECX=00eff8a8 DS=0177 ESI=00a19500 FS=0fa7
EDX=0066fa0c ES=0177 EDI=00a19500 GS=0000
Bytes at CS:EIP:

Stack dump:
00ee9998 00a1ae90 00000000 0066fa0c 80000000 00a19500 0000012f 00a74df0 0066fa14
00ee6972 00f0cf44 00000000 00000000 0066fa5c 0066fa5c 00ee8304 \\

Comment 6

15 years ago
Sorry.. on my previous post.. I forgot to mention.. The sites vary on these..
from mail.yahoo.com abcnews.com popsci.com google.com with no discernable
pattern to why/when.

..and towards the end there when the wierd dlls start popping up.. I had to
reboot cause my system was destabalized and grinding to a halt.
(Reporter)

Comment 7

15 years ago
re comment 5 / 6, what version are you running? (help-about mozilla) - I will
guess 1.7a as it was extremely unstable for me and talkback didn't work either.
Please updgrade to 1.7b which was just released, it seems more stable and
talkback (allegedly) works.
I haven't made 1.7b crash at the original crash site yet, but that does not mean
this particular bug is fixed..
(Reporter)

Comment 8

15 years ago
Had a crash at the bugsite with 1.7b (20040316). Talkback still isn't working
for me ("404 Not Found" deep in it's chat with mothra.mozilla.org).
Anyway, sorry no feedback id, but you do get this:

MOZILLA caused an invalid page fault in
module GKLAYOUT.DLL at 016f:60276442.  (address diferent from last time, no
surprise I guess)
Registers:
EAX=00000000 CS=016f EIP=60276442 EFLGS=00010246
EBX=0166eaa8 SS=0177 ESP=00649094 EBP=0064909c
ECX=006490ec DS=0177 ESI=006490ec FS=309f
EDX=00000000 ES=0177 EDI=006492c0 GS=0000
Bytes at CS:EIP:
8b 48 18 e8 1a 1f 0a 00 89 86 90 00 00 00 8b 46 
Stack dump:
00000004 006490ec 006490c0 602761b8 01864c20 ffffffff ffffffff 00000000 00000000
006492c0 00649378 00649264 602afe3f 01864c20 006492c0 00000000 
(Reporter)

Comment 9

15 years ago
re comment 8, see Incident Id TB7691Z
(tried a different ISP - sigh....)

Comment 10

15 years ago
Thanks for the TB ID.

*** This bug has been marked as a duplicate of 243528 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: Crash in gklayout.dll at this site (intermittent) → Crash in gklayout.dll at this site (intermittent) [@ nsHTMLReflowState::Init ]
(Assignee)

Updated

8 years ago
Crash Signature: [@ nsHTMLReflowState::Init ]
You need to log in before you can comment on or make changes to this bug.