calling openTopWin() produces alert with navigator.xul cannot be found

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: bugzilla, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
if you call openTopWin() you get an alert saying:
"the file /content/navigator.xul cant be found. please check the location and
try again"

perhaps the function openTopWin should be removed for tbird?
(Reporter)

Comment 1

15 years ago
if we're in Thunderbird we should just call
messenger.launchExternalURL(url)

from inside openTopWin()
this way you can always call openTopWin to open a new window!

Comment 2

15 years ago
Fork utilityOverlay.js?

Comment 3

15 years ago
I've just run in to (what I believe to be) this bug when clicking on a mailto
link in an HTML email:

<a href="mailto:xxx@yyy.com" target="_new">xxx@yyy.com</a>

That's quite serious from a usability perspective, as the link doesn't work.

I'm using TB 0.6 on Win2000.
Created attachment 151359 [details]
Page containing link

I Copy-pasted text from this page in Firefox to the compose window in
Thunderbird. The resulting link pops up the error message when clicked in the
Thunderbird compose window. If I then send myself that email, the link works
(although the provided link does not point anywhere). I also noticed that it is
necessary for "http:" to be in the window.open URL, as the error message is not
shown without it.
I experience this bug when copy pasting a javascript popup link into a compose
window. Clicking on the link then gives the error. If I then send the message to
myself, the link works fine from my Inbox. I have experimented a bit, and I seem
to have found an easy way to reproduce my problem. See my attachment above for
details.

Also, can someone please change "cant" to "cannot" in the summary? Having the
exact text of the error message in the summary would increase the likelihood of
finding the bug and prevent dupes.
Summary: calling openTopWin() produces alert with navigator.xul cant be found → calling openTopWin() produces alert with navigator.xul cannot be found
QA Contact: front-end
openTopWin is gone; target="_new" works (though with a currently unavoidable extra window, for a mailto); clicking on a link in message compose doesn't currently open it, and between us Gavin and I couldn't quite remember what it was even like in 2004, so, WFM.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.