Status

()

Firefox
General
RESOLVED DUPLICATE of bug 206651
14 years ago
14 years ago

People

(Reporter: Mac OS X Angel, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Firefox (and Thunderbird) have a habit of over-using Sheets whenever a dialog is
needed. This results in sheets sliding in and out a lot; in some cases, the user
gets the following:
a) a panel slides out as a sheet
b) clicking an option results in the panel retracting
c) a confirmation dialog box (Yes/No/Cancel/Save/etc) slides out as a sheet
d) the user deals with the dialog box, which then retracts
e) the original panel slides back out
f) depending on the action chosen in the confirmation dialog, the original panel
may immediately retract.

Reproducible: Always
Steps to Reproduce:
1. Click Firefox > Preferences > Web Features > Permissions
Actual Results:  
Multiple sheets sliding in and out.

Expected Results:  
Apple's Aqua UI guidelines specify that a sheet should be used for a dialog that
deals with a document (eg: saving, opening, printing a document). However a
dialog that deals with the whole application (eg: preferences) should be a
separate application-modal box.

Compare to Safari and Mac OS X Mail.

The following is a link to Apple's HI guidelines:

http://developer.apple.com/documentation/UserExperience/Conceptual/OSXHIGuidelines/XHIGDialogs/chapter_17_section_2.html#//apple_ref/doc/uid/20000962/CJECBHJE

Comment 1

14 years ago
Thanks for your report :) It's actually already being looked at: bug 206651

If you have anything further to add to that bug, feel free to add comments there.

cheers

*** This bug has been marked as a duplicate of 206651 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
Oh, see also bug 222364 for the same issue with the About dialog
You need to log in before you can comment on or make changes to this bug.