If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Filters and "Search Messages" always hit all emails

RESOLVED EXPIRED

Status

MailNews Core
Filters
--
major
RESOLVED EXPIRED
14 years ago
9 years ago

People

(Reporter: Stefan Will, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla Thunderbird 0.5 (20040207)

I configured a mail filter that is supposed to filter incoming emails from my 
IMAP account into a given folder on the IMAP server. It always moves ALL 
messages, not just the ones that should have matched the filter. The same 
happens if I use the "search messages" panel from the tools menu. I configured 
it to return all messages that match the following rule "Subject 
contains 'event'" and leaving all the other settings at their defaults (namely 
the search subfolders flag is set, and also match any is active). When I run 
the search, all of the messages in my inbox are returned, not just the ones 
that match my query.


Reproducible: Always
Steps to Reproduce:
1. Set up and connect to an IMAP account (that's at least what I tried it with)
2. Open the "Search Messages" window and create a simple filter rule
3. Run the search and notice that all messages were matched
4. Set up a filter rule that moves all matching messages to a specific folder
5. Run the filter
6. Notice that ALL messages where moved
Actual Results:  
All messages matched

Expected Results:  
Only the messages that match my filter rules should be returned/moved

Comment 1

14 years ago
it'd probably help if you found out what type of imap server you have, perhaps
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html would be useful.
(Reporter)

Comment 2

14 years ago
I don't know if it's very helpful, but here are the first few lines of the IMAP 
logger output. The server identification is "GMX IMAP4 StreamProxy ready." I 
guess it's a custom implementation ?

0[254638]: 2bcda18:mail.gmx.net:NA:SetupWithUrl: clearing 
IMAP_CONNECTION_IS_OPEN
1944[2ba3258]: ImapThreadMainLoop entering [this=2bcda18]
1944[2ba3258]: 2bcda18:mail.gmx.net:NA:ProcessCurrentURL: entering
1944[2ba3258]: 2bcda18:mail.gmx.net:NA:ProcessCurrentURL:imap://stefan.will%
40gmx.net@mail.gmx.net:143/select%3E/INBOX:  = currentUrl
1944[2ba3258]: ReadNextLine [stream=2bd0af0 nb=35 needmore=0]
1944[2ba3258]: 2bcda18:mail.gmx.net:NA:CreateNewLineFromSocket: * OK GMX IMAP4 
StreamProxy ready.

1944[2ba3258]: 2bcda18:mail.gmx.net:NA:SendData: 1 capability

1944[2ba3258]: ReadNextLine [stream=2bd0af0 nb=55 needmore=0]
1944[2ba3258]: 2bcda18:mail.gmx.net:NA:CreateNewLineFromSocket: * CAPABILITY 
IMAP4 IMAP4rev1 AUTH=LOGIN AUTH=CRAM-MD5

1944[2ba3258]: ReadNextLine [stream=2bd0af0 nb=27 needmore=0]
1944[2ba3258]: 2bcda18:mail.gmx.net:NA:CreateNewLineFromSocket: 1 OK CAPABILITY 
completed

1944[2ba3258]: 2bcda18:mail.gmx.net:NA:SendData: 2 authenticate login

1944[2ba3258]: ReadNextLine [stream=2bd0af0 nb=16 needmore=0]
1944[2ba3258]: 2bcda18:mail.gmx.net:NA:CreateNewLineFromSocket: + VXNlcm5hbWU6

1944[2ba3258]: 2bcda18:mail.gmx.net:NA:SendData: Logging suppressed for this 
command (it probably contained authentication information)
1944[2ba3258]: ReadNextLine [stream=2bd0af0 nb=16 needmore=0]
1944[2ba3258]: 2bcda18:mail.gmx.net:NA:CreateNewLineFromSocket: + UGFzc3dvcmQ6

1944[2ba3258]: 2bcda18:mail.gmx.net:NA:SendData: Logging suppressed for this 
command (it probably contained authentication information)
1944[2ba3258]: ReadNextLine [stream=2bd0af0 nb=22 needmore=0]
1944[2ba3258]: 2bcda18:mail.gmx.net:NA:CreateNewLineFromSocket: 2 OK LOGIN 
completed
(Reporter)

Comment 3

14 years ago
The quick search box on top of the folder view ("Subject or Sender contains") 
works as expected, by the way.

Comment 4

13 years ago
  "me too" when using "Tools/Run Filters",   If any msgs in the selected folder
match the filter rule, then All msgs in the folder at matched and processed by
that first matched filter rule.
  "me too" when using "Message Fitlers/Run Now".  If any msgs in the selected
folder match the selected filter rule, then all msgs in the folder are processed
by the rule.
  Oddly enough, normal filtering for incoming mail works fine.

  I see msgs like 
--
1078964896[8082520]: considering playing queued
url:imap://keith_hopkins@snoexc03.asiapacific.cpqcorp.net:143/listfolder>/Telecom/CriticalSupport/Telecom
NZ and NEC NZ
1078964896[8082520]: creating protocol instance to play queued
url:imap://keith_hopkins@snoexc03.asiapacific.cpqcorp.net:143/listfolder>/Telecom/CriticalSupport/Telecom
NZ and NEC NZ
1078964896[8082520]: failed creating protocol instance to play queued
url:imap://keith_hopkins@snoexc03.asiapacific.cpqcorp.net:143/listfolder>/Telecom/CriticalSupport/Telecom
NZ and NEC NZ
--
  repeated over and over again (possibly once per rule processed?)

Microsoft Exchange Server 2003 IMAP4rev1 server version 6.5.7226.0

Mozilla 1.7
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616
Product: MailNews → Core
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → EXPIRED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.