Closed Bug 235079 Opened 21 years ago Closed 21 years ago

SQL syntax error in group selection query on show_bug.cgi where bug number starts with zero

Categories

(Bugzilla :: Creating/Changing Bugs, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 217627

People

(Reporter: myk, Assigned: myk)

References

()

Details

If you try to load a bug in show_bug.cgi where the bug number contains a leading
zero (f.e. 0600) you get an SQL syntax error in a query selecting groups:

undef error - DBD::mysql::st execute failed: You have an error in your SQL
syntax. Check the manual that corresponds to your MySQL server version for the
right syntax to use near 'WHERE isbuggroup' at line 1 [for statement ``SELECT
DISTINCT groups.id, name, description, bug_group_map.group_id IS NOT NULL,
user_group_map.group_id IS NOT NULL, isactive, membercontrol, othercontrol FROM
groups LEFT JOIN bug_group_map ON bug_group_map.group_id = groups.id AND bug_id
= 0600 LEFT JOIN user_group_map ON user_group_map.group_id = groups.id AND
user_id = 27300 AND NOT isbless LEFT JOIN group_control_map ON
group_control_map.group_id = groups.id AND group_control_map.product_id = WHERE
isbuggroup'']) at Bugzilla/DB.pm line 66

There shouldn't be leading zeros on bug numbers generally, but this certainly
shouldn't be the result.  Since the user probably wants the bug represented by
the number without the leading zero (and obvious that they got it wrong if they
really want some other bug), we should just strip the zero and give them the bug
that number represents.

*** This bug has been marked as a duplicate of 217627 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.