kat5kaos.com - form submit results in 'location is not a registered protocol' error along with blank page result

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Clarence Risher, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031030

At the example URL try to log in (any made up info is fine, just get the captcha
numbers correct).  I get a blank page (<html><body></body></html>) along with a
popup dialog that tells me 'location is not a registered protocol'.  I cannot
find anything on the form that might produce this error, so I am at a loss as to
how to even begin to fix it on the site.  My only guess is that maybe somehow
Mozilla is mistakenly implementing some sort of protocol guessing (like using
ftp:// for ftp.foo.com) here.

Reproducible: Always
Steps to Reproduce:
1. Visit www.kat5kaos.com
2. Fill out login form
3. Submit

Actual Results:  
Blank page, popup error dialog.

Expected Results:  
Proper form submission, log into site (or site provided error page for wrong
login info)
Confirming with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a)
Gecko/20040210 Firebird/0.8.0+

Protocol guessing seems to work as typing "location.mooo.de" (which does have an
A record) gets a "http://" in front...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

15 years ago
Component: Location Bar → HTML: Form Submission
Please create an HTTP log of this bug happening(see
http://www.mozilla.org/projects/netlib/http/http-debugging.html for details) and
attach it here.  Try to not load any extraneous content other than the two pages
in question....
Created attachment 141950 [details]
HTTP log as wished
Attachment #141950 - Attachment mime type: application/octet-stream → application/zip
The site sends the following HTTP header:

>  refresh: 0; Location: modules.php?name=Your_Account&stop=1

As I understand, the syntax of such headers is:

  "refresh: time; URL"

So mozilla gets a URL of "Location: modules.php?name=Your_Account&stop=1"

Darin, did I get the above right?
actually I believe the syntax requires an added URL= in front of the url,
although mozilla probably does not require that.
(Reporter)

Comment 6

15 years ago
It seems you are correct, the fault lies with the site (more specifically with
an old default phpnuke configuration) and not with Mozilla.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
To tech evang until this is resolved....
Assignee: location-bar → english-us
Status: REOPENED → NEW
Component: HTML: Form Submission → English US
Product: Browser → Tech Evangelism
QA Contact: english-us
Version: Trunk → unspecified

Comment 8

14 years ago
Conforming summary to TFM item 10 at 
http://www.mozilla.org/projects/tech-evangelism/site/procedures.html#file-new
Summary: form submit results in 'location is not a registered protocol' error along with blank page result → kat5kaos.com - form submit results in 'location is not a registered protocol' error along with blank page result
fixed
Status: NEW → RESOLVED
Last Resolved: 15 years ago10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.