Menu action "Select All" (ALT + A) does not select the XML/text content.

RESOLVED DUPLICATE of bug 234913

Status

()

Core
Selection
--
minor
RESOLVED DUPLICATE of bug 234913
14 years ago
14 years ago

People

(Reporter: Os Moma, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

I visited the www.userlinux.com's "RSS feed" page. The content is shown as XML
(text) because there is no CSS related to it. That's OK.  But when I tried to
"Select All" on that page, the browser became veeeery slow, and it could not do
the selection.

Is the parsing of XML a slow process ?


Reproducible: Always
Steps to Reproduce:
0.The Mozilla browser is the only visible app running. The PC is newly booted.
1.Goto http://www.userlinux.com/cgi-bin/wiki.pl?action=rss
2.The content is shown as XML-text.
3.Do "Select All" from main-meny or popup-menu.
4.Browser stands by for a while (=slow).
5.No (visible) selection is done. 
--


Actual Results:  
No selection is done.

This is not any severe error. You can just "save page as" to a file or select it
by dragging the mouse.



Expected Results:  
Expected *instant* *quick* selection of that peace of text.

1) Both Mozilla v1.4 and v1.6 behave similarly.

2) FireFox browser v0.8:
   Like Mozilla browser. It fails to "Select All".

3) Knoqueror: It cannot understand the XML so it just shows it as plain text.
"Select all" is very quick.

4) This machine is:
IBM PC with 512 MB RAM, 1GB swap.

$ uname -a
Linux kernel 2.6.1-rc3 #2 Fri Jan 9 14:18:45 CET 2004 i686 i686 i386 GNU/Linux
Fedora Core.
--

Comment 1

14 years ago
Dupe of bug 234913. See http://bugzilla.mozilla.org/show_bug.cgi?id=234913#c9.

*** This bug has been marked as a duplicate of 234913 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Summary: Menu action "Select All" (ALT + A) does not select the XML/text content. → Menu action "Select All" (ALT + A) does not select the XML/text content.
You need to log in before you can comment on or make changes to this bug.