Mozilla Crash apparently from authentication dialog with news server.

RESOLVED DUPLICATE of bug 215085

Status

()

Core
XPCOM
--
critical
RESOLVED DUPLICATE of bug 215085
14 years ago
11 years ago

People

(Reporter: John Malmberg, Assigned: dougt)

Tracking

Trunk
DEC
OpenVMS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; OpenVMS AlphaServer_DS10_617_MHz; en-US; rv:1.5) Gecko/20040116

After leaving Mozilla up overnight, 3 times now I have found it crashed with the
crash dump below.

The two changes are the upgrade to the build mentioned above in this bug report,
and my ISP changing to a newserver that requires authentication.

Since that change, the login box is repeatedly poping up at seemingly random
intervals prompting for the login information that Mozilla has already recorded
for it which is of course a different bug 219162 that for pop3 access is
reported to be fixed in this release.

As near as I can determine from the crashdump, it is after one of these times
that the newserver is requesting authorization that Mozilla crashes with an
access violation.

It has taken me until the third crash to get the complete crash dump.

Reproducible: Sometimes
Steps to Reproduce:
1. Start Mozilla in the morning and connect to the news server
2. Use it again in the evening.
3. Leave it overnight.  Seems to take about 48 hours of operation before the
crash will occur.

Actual Results:  
Crash dump.  Truncated because of Bugzilla data length restrictions.

%SYSTEM-F-ACCVIO, access violation, reason mask=00, virtual address=000000000000
0014, PC=0000000000AC19E0, PS=0000001B
%TRACE-F-TRACEBACK, symbolic stack dump follows
  image    module    routine             line      rel PC           abs PC
 LIBXPCOM  PLEVENT  PL_IsQueueNative    41701 0000000000001230 0000000000AC19E0
 LIBXPCOM  NSEVENTQUEUE  IsQueueNative  26713 00000000000014DC 0000000000AB7C9C
 LIBNSAPPSHELL  NSAPPSHELLSERVICE  Observe
                                        78397 0000000000009CC4 000000000200FEB4
 LIBXPCOM  NSOBSERVERSERVICE  NotifyObservers
                                        26616 0000000000000C24 0000000000A43014
 LIBXPCOM  NSEVENTQUEUE  NotifyObservers
                                        26587 0000000000000DBC 0000000000AB757C
 LIBXPCOM  NSEVENTQUEUE  InitFromPRThread
                                        26539 00000000000005B4 0000000000AB6D74
 LIBXPCOM  NSEVENTQUEUESERVICE  MakeNewQueue
                                        25959 0000000000000DB8 0000000000AB9CA8
 LIBXPCOM  NSEVENTQUEUESERVICE  PushThreadEventQueue
                                        26078 00000000000016E8 0000000000ABA5D8
 LIBEMBEDCOMPONENTS  NSWINDOWWATCHER  Push
                                        70633 000000000000129C 0000000000CF168C
 LIBEMBEDCOMPONENTS  NSWINDOWWATCHER  OpenWindowJS
                                        70887 0000000000002744 0000000000CF2B34
 LIBEMBEDCOMPONENTS  NSWINDOWWATCHER  OpenWindow
                                        70773 0000000000001EE4 0000000000CF22D4
 LIBEMBEDCOMPONENTS  NSPROMPTSERVICE  DoDialog
                                        26469 0000000000004CB4 0000000000CF0014
 LIBEMBEDCOMPONENTS  NSPROMPTSERVICE  Prompt
                                        26240 0000000000003134 0000000000CEE494
 LIBEMBEDCOMPONENTS  NSPROMPT  Prompt   19201 0000000000001238 0000000000CEAE28
 LIBWALLET  SINGSIGN  SINGSIGN_Prompt   58847 000000000000B1D8 0000000003EFDA38
 LIBWALLET  NSWALLETSERVICE  Prompt     51810 0000000000004FF4 0000000003EDF574
 LIBMSGNEWS  NSNEWSFOLDER  GetGroupUsernameWithUI
                                        75699 000000000000BD98 0000000003323CA8
 LIBMSGNEWS  NSNNTPPROTOCOL  BeginAuthorization
                                        77861 000000000000F818 000000000334CEE8
 LIBMSGNEWS  NSNNTPPROTOCOL  ProcessProtocolState
                                        80220 000000000001A17C 000000000335784C
 LIBMSGBASEUTIL  NSMSGPROTOCOL  OnDataAvailable
                                        62417 00000000000038B4 0000000003017A74


Expected Results:  
Obviously it should not have crashed.
(Reporter)

Comment 1

14 years ago
This appears to be related to bug 214533.
(Reporter)

Comment 2

14 years ago
Mozilla 1.7
Mozilla/5.0 (X11; U; OpenVMS AlphaServer_DS10_617_MHz; en-US; rv:1.7) Gecko/20040621

Bug is still present, so is  bug 214533, even though it is marked as fixed for 1.7b.
Product: MailNews → Core

Comment 3

13 years ago
reporter: you could attach stacks as attachments, is it possible for you to
build your own versions with symbols?
Assignee: sspitzer → dougt
Component: Networking: News → XPCOM
QA Contact: stephend
(Reporter)

Comment 4

13 years ago
Created attachment 176966 [details]
listing of crash carsh dump

Because of a bug in the OpenVMS port of mozilla, the only way I could get a
text file imported is by putting it in a GZIPPED TARBALL.
(Reporter)

Comment 5

13 years ago
At this time, I am not able to do my own build of Mozilla.

Comment 6

13 years ago
hrm, note to self: bug 215085 has a reference to a patch which handles at least
a few possible problems relating to the call stack presented in this bug.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 8

13 years ago
Mozilla 1.7
Mozilla/5.0 (X11; U; OpenVMS AlphaServer_DS10_617_MHz; en-US; rv:1.7) Gecko/20040621

Bug still seems to be present.  The news server operator has improved uptime
which makes this bug trip less often.

Comment 9

11 years ago
dump attached to this bug so duping to bug 215085 which may be the most useful resolution, given that reporter is gone,
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 215085
You need to log in before you can comment on or make changes to this bug.