Overlapping text on selecting "Online" button (top right)in window.

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English Other
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Jeremy Morton, Unassigned)

Tracking

Details

(Whiteboard: [bug248549notfixed], URL)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

If you go to "http://www.halifax.co.uk/creditcards/balance_transfer.shtml" and
then select the "Online" button (top right) and then the "Start" button. The
text in the resulting window is not rendered correctly. This incorrect rendering
also occurs in the latest version of Mozilla. In the latest Opera and IE6 the
text is rendered fine.

Reproducible: Always
Steps to Reproduce:
1. Go to "http://www.halifax.co.uk/creditcards/balance_transfer.shtml"
2. Select the "Online" button at the top right of the window.
3. Select the "Start" button.


Actual Results:  
The text before the fields in the resulting window overlaps.  The latest version
of Mozilla also displays in the same way. IE6 and Opera display fine.

Expected Results:  
Non overlapping text.

Comment 1

15 years ago
If you get the same thing in Mozilla, then don't file it as a Firefox-specific bug.
->Browser/Layout
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Browser
QA Contact: core.layout
Summary: Overlapping text on selecting "Online" button (top right)in window. → Overlapping text on selecting "Online" button (top right)in window.
Version: unspecified → Trunk

Comment 2

15 years ago
The text (in black) is in a span with display:block and height:30px (and no
specified overflow so it defaults to visible). Apparently Opera and IE are
ignoring the display, and therefore also the height since span is normally
inline and height doesn't apply to inlines. 

Mozilla's rendering is correct, 
-> Invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
It's worse, actually.  IE simply mis-implements height (on blocks) and Opera has
copies that bug in quirks mode.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Evang.
Assignee: nobody → english-other
Component: Layout → English Other
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: core.layout → english-other
Hardware: PC → All
Version: Trunk → unspecified

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 243604 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Whiteboard: [bug248549notfixed]

Comment 6

14 years ago
What's with the [bug248549notfixed] in the status whiteboard? (AFAIK) this bug
has nothing to do with that...
it returns an error now but i get the same error in IE7
Status: NEW → RESOLVED
Last Resolved: 15 years ago9 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.