the size of bugs.version is too short

VERIFIED DUPLICATE of bug 9352

Status

()

Bugzilla
Bugzilla-General
P3
major
VERIFIED DUPLICATE of bug 9352
19 years ago
6 years ago

People

(Reporter: Richard, Assigned: justdave)

Tracking

Details

(Reporter)

Description

19 years ago
I tried to generate a query today.  I received a 'zero boogs' response,
however, the report summary returned 5 bugs.  Upon inspection I noticed that
the version text in the version table is defined as tinytext and as varchar(16)
in the bugs table.  Since the value in the version table was greater than 16,
the query failed because only 16 chars of the version were stored.

I fixed it by changing the version to varchar(50) in the bugs table.  This is
probably not the right answer.

The right answer is going to be creating a 'versionid' and assigning the id to
the individual bugs.

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 1

19 years ago
*** This bug has been marked as a duplicate of 9352 ***

Comment 2

19 years ago
VERIFY duplicate
Status: RESOLVED → VERIFIED
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Assignee: terry → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
QA Contact: matty
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.