Last Comment Bug 235171 - [FIX]TEXTAREA narrow than set by COLS= (newlines don't end unquoted attributes)
: [FIX]TEXTAREA narrow than set by COLS= (newlines don't end unquoted attributes)
Status: RESOLVED FIXED
: qawanted, regression
Product: Core
Classification: Components
Component: HTML: Parser (show other bugs)
: Trunk
: All All
: P1 normal (vote)
: mozilla1.7beta
Assigned To: Boris Zbarsky [:bz] (still a bit busy)
:
: Andrew Overholt [:overholt]
Mentors:
http://en.wikipedia.org/w/wiki.phtml?...
: 235340 235497 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-21 17:17 PST by noririty
Modified: 2004-02-24 17:54 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix (5.14 KB, patch)
2004-02-22 16:12 PST, Boris Zbarsky [:bz] (still a bit busy)
choess: review+
jst: superreview+
Details | Diff | Splinter Review

Description noririty 2004-02-21 17:17:05 PST
- Occurs On 20040219
- Doesn't Occur On 20040221
Comment 1 noririty 2004-02-21 17:19:48 PST
oops, it was opposite.
- Doesn't Occur On 20040219
- Occurs On 20040221
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2004-02-21 23:10:54 PST
What are the times to go with those dates?  What about 2004-02-20-XX?
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2004-02-22 16:11:38 PST
This is a parser issue (look in DOM inspector and notice that the cols attr
isn't even set).
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2004-02-22 16:12:23 PST
Created attachment 141974 [details] [diff] [review]
Fix

The idea here is to only allow newlines inside quoted attrs.  Other attrs
should be terminated by newlines.
Comment 5 Boris Zbarsky [:bz] (still a bit busy) 2004-02-22 16:13:44 PST
This is a regression from bug 137315 
Comment 6 Johnny Stenback (:jst, jst@mozilla.com) 2004-02-22 21:37:41 PST
Comment on attachment 141974 [details] [diff] [review]
Fix

+      else if(aAllowNewlines && ch == kCR) {
...
>+      else if(aAllowNewlines && ch == kNewLine) {

Would it not generally be faster to check ch == k... before checking
aAllowNewlines?

sr=jst
Comment 7 Boris Zbarsky [:bz] (still a bit busy) 2004-02-22 22:48:59 PST
Hmm.. probably.  I will change that before checking in.
Comment 8 Boris Zbarsky [:bz] (still a bit busy) 2004-02-23 14:50:53 PST
*** Bug 235340 has been marked as a duplicate of this bug. ***
Comment 9 Boris Zbarsky [:bz] (still a bit busy) 2004-02-24 16:46:12 PST
Checked in, with that change.
Comment 10 Boris Zbarsky [:bz] (still a bit busy) 2004-02-24 17:54:42 PST
*** Bug 235497 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.