builds with --enable-single-profile crash at startup

RESOLVED DUPLICATE of bug 202221

Status

SeaMonkey
Startup & Profiles
RESOLVED DUPLICATE of bug 202221
14 years ago
14 years ago

People

(Reporter: Jamie Zawinski, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Building the 1.6 release tarball with options that include
"--enable-single-profile" results in an executable that exits with status 1
before ever mapping a window.

These are the options I used that produced the non-running executable.
Removing only "--enable-single-profile" from this list resulted in a build
that works.

        ./configure \
           --disable-mailnews --disable-ldap --disable-postscript \
           --disable-xprint --disable-accessibility --disable-composer \
           --enable-plaintext-editor-only \
           --enable-single-profile \
           --disable-calendar \
           --enable-extensions=default,-irc \
           --disable-tests \
           --disable-installer \
           --disable-logging \
           --enable-crypto \
           --disable-debug --enable-optimize --enable-strip \
           --prefix=/usr/local


If "--enable-single-profile" is not a supported option for this branch of
mozilla, it ought to print a warning, or at worst be ignored, instead of
breaking things...

(The reason I was trying that option at all was in the hope of ending up with a
build that did not include a profile manager at all, in the hope that this might
mitigate the problems described in bug #211505 .)

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
single profile is not supported as a Mozilla build option

dupe of "--enable-single-profile needs better description", which is to document
this and/or add appropriate checks to configure.

*** This bug has been marked as a duplicate of 202221 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.