loss of settings when integrating virus check programme

RESOLVED DUPLICATE of bug 221386

Status

RESOLVED DUPLICATE of bug 221386
15 years ago
14 years ago

People

(Reporter: christian.madelung, Assigned: sspitzer)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.6) Gecko/20040113

Mozilla with mail function is installed and fully configured. I have z pop
accounts that I handle within the same profile. All works fine.

I want to integrate an anti-virus programme of Gdata or Kapersky Labs. These
programms monitor the pop account conections to the actual main servers via the
local host "server" 127.0.0.1 . The anti-virus programme takes over the settings
of the mail manager and scans the mail server for new emails. The mails are then
scaned for viruses within the localhost "server", before being dropped in the
corresponding mail bos of the mozilla mail.

The settings now are: Mail server: 127.0.0.1 and the user name:
pop.server.com:username

Certain settings of the mail manager can now not be changed or are lost in total
e.g. copies of sent mails or handling of  draft etc. When a new selection is
made, e.g. to store sent mails in the sent folder of the defined mail box, then
upon closing the mail manager, the settings are lost. At best the sent mails
have a copy saved in the general folder, while in some cases. no copies of the
sent mails are stored anywhere.

Reproducible: Always
Steps to Reproduce:
1.Install Mozilla
2.Configure Mail
3.Test and operate Mail
4. Install anti-virus programme

Actual Results:  
The same results every time

Expected Results:  
allow settings on where copies of sent mails are to be stored to be defined.

Problem occurs on Windows XP and Windows 2000 Prof. environments.

Operation is instable.
Does the Anti-Virus produkt change the Mozilla settings itself ?
(Reporter)

Comment 2

15 years ago
(In reply to comment #1)
> Does the Anti-Virus produkt change the Mozilla settings itself ?
> 
No the Anti-Virus does not change the settings.  It can configurate the server
settings - yes, (in my case I configure the mail server settingsmanually) but no
other settings are changed, except that the previous settings in the mail
manager e.g. where to save a copy of a sent email, etc. are "like deactivated",
meaning they cannot be changed or reconfigured. The setting is usually indicated
by the interactive icon with the black dot. No matter which combination you
select, after closing the window, the settings are not applied.

After de-installing the Anti-Virus, the program does not return to "normal".
Mozilla needs to be deinstalled and reinstalled for an original functionality to
be achieved.

On a test system I yesterday was able to replicate the same condition with
another software (Anti-Virus was not installed). The software is an an AntiSpam
programme, which however works on the same principle.

If you want a copy of the SW for test purposes, please let me know.
See Bug 213300 and bugs refered by Bug 213300 for damges on Mozilla Mail
functions due to prefs.js change by anit-virus softwares.  
(Reporter)

Comment 4

15 years ago
What professional anti-virus software is recommendable? Any ideas for Spam-Killers?

The problem is that the developers of the above mentioned SW all state
workability with Netscape / Mozilla. As we find, NOT TRUE.

There were a couple of Spam-Killers that had independant access to the mail
server and did their continuous filtering. If you have a pass through of a pass
through in order to get clean mails, it does not help the situation.

Thank you for the assistance.

*** This bug has been marked as a duplicate of 221386 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Dr. Christian Madelung, bug 221386 is, I think, mailnly for problems caused by
inconsistency made by hand, although some comments talk about change by
"anti-virus software.
Iinconsistency by anti-virus software and inconsistency by hand are same, but
inconsistency" by anti-virus is different problem from manual prefs.js corruption.
I think Bug 221386 is a kind of evengelism bug.
And I think this bug is to be closed as DUPE of Bug 235124 instead of Bug 221386
for refference by other people.
(Reporter)

Comment 6

15 years ago
I also think the inconsistancy is still an issue.

I followed comment #18 of Bug 213300 - the recovery worked fine.

Then followed again tried to manually set the server and user name manually for
anti-virus to be set. That works OK.

But again the settings in Copies and Folders are lost.
The prefs.js has the following settings changed - whether that is correct or not
I do not know:

user_pref("mail.server.server1.OrigServer", "127.0.0.1");
...
user_pref("mail.server.server1.realhostname", "127.0.0.1");
user_pref("mail.server.server1.realusername", "username");

When the realhostname is changed back to what it is supposed to be, then the
settings in "Copies and Folders" work again.

BUT, then the scan is defunct and the anti-virus program might try to reinstall
the settings. Also I have found, that when there are 2 or more POP accounts with
the same host, then the scan does not work. The username should then include the
"hostname:username" in oder for the program to finds its way.

But the main issue are the settings. I can scrap such an anti-virus program, if
there is one that does not cause such havoc.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Product: Browser → Seamonkey
Bug 235124 was already closed as DUP of Bug 221386.
Dr. Christian Madelung, close this bug as DUP of any bug you like in bug 213300
or bug 221386 or 235124, please.
Closing DUP of Bug 221386

*** This bug has been marked as a duplicate of 221386 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.