national-lottery.co.uk - can't register or login with Mozilla/Firefox

RESOLVED DUPLICATE of bug 226258

Status

Tech Evangelism Graveyard
English Other
RESOLVED DUPLICATE of bug 226258
15 years ago
3 years ago

People

(Reporter: Richard Lloyd, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
The official UK national lottery site at http://www.national-lottery.co.uk/ has
online games you can pay to play. You first register with the site at
https://www.national-lottery.co.uk/player/registration.do - or rather you can't
because it's got a double block (firstly on OS - only likes Windows or Mac OS)
and then secondly on browser (only likes IE 5.5, 6, AOL 7 or Netscape 7 [!!]).

So, there's me coming in with Mozilla 1.6 on Fedora Core 1 and I get
"Incompatible OS". If I fake the agent string to make it look like I'm on "NT
5.1" (Windows XP), I then get "incompatible browser". If I then fake it a second
time to be IE 6 SP1, I get through and - wonders of wonders - it all works
perfectly under Mozilla !

I have phoned up Camelot (who run the site) many times over the past 18 months
to complain about this and they've just been stonewalling, claiming that they
were "too rushed to add Mozilla-based browsers to the testing suite". This
despite the fact they let in the now-defunct NS 7.1, which is based on the same
rendering engine as Mozilla 1.4 of course. Needless to say, I refuse to play
their online games until they fix it.

There's contact info (including help@national-lottery.co.uk if you want to try
the e-mail route) at
http://www.national-lottery.co.uk/player/p/about/contact.jsp if anyone wants a
go at persuading them to hurry up and remove their double block...

Comment 1

14 years ago
ccing self.

This bug is a dupe of http://bugzilla.mozilla.org/show_bug.cgi?id=226258 (but i
cant set this one as a dupe because i dont have enough access.

Comment 2

14 years ago
I've contacted the National Lottery technical helpline this morning, about the
fact they're still blocking Mozilla, while allowing access with Netscape 7.x.

I pointed out that since Netscape 7.x and Mozilla 1.x are technically the
same thing under the hood, and that Netscape 7.1 is built upon and older
version of Mozilla, there is no need to be blocking Mozilla.

The telephonist took my name and phone number, informed me that this matter
will be escalated to the relevant people in the technical department, and
that someone will phone me back in the next couple of days.

Here's hoping this will soon be resolved with a possitive result . . . 

Comment 3

14 years ago
I e-mailed the site today and got this response back:

>As we are continually developing our website, based on customers
>feedback, support for Mozilla will be introduced in the near future.

So hopefully the site will be soon usable. It's probably still worth e-mailing
them though, just in case they're trying to get people like us to shut up ;)
(Reporter)

Comment 4

14 years ago
Just a note that the registration/login process is no longer blocking Linux as
an OS, but that doesn't help us much because they are *still* blocking all
Mozilla and Firefox releases...grrr...we're almost 2 years into this...

I downloaded the User Agent Switcher and set up an "IE on Linux" setting thus:

Description: Internet Explorer 6 (Linux)
User Agent: Mozilla/5.0 (X11; U; MSIE 6.0; Linux i686; en-GB; rv:1.7; WAKE UP
WEBMASTER: Stop blocking Mozilla you idiot!) Gecko/20040619

Simulates IE 6.0, Mozilla 1.7, Linux and an insult to the lazy Webmaster in one
user agent string :-) Guess what, it gets through their naff checking and lets
you use the pages. User Agent Switcher isn't a particularly good extension (it's
UI needs a revamp too - not easy to re-order or delete things) because you
really only want it on a per-site basis of course.

*** This bug has been marked as a duplicate of 226258 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.