If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

'Get all messages' does not honor 'Use secure authentication' of individual accounts correctly

VERIFIED INVALID

Status

MailNews Core
Networking: POP
VERIFIED INVALID
14 years ago
9 years ago

People

(Reporter: aceman, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040128 Firebird/0.8.0+

MailNews seems to ignore the setting of 'use secure authentication' in the
individual accounts.

Reproducible: Always
Steps to Reproduce:
0.Enable POP3 logging
1.Make 2 POP3 mail accounts
2.Select 'use secure authentication' in 1 of them (and verify that it works with
the server)
3.Activate the other one
4.Use 'get all new messages' - mail should be fetched correctly
5.See the logs. You should see that mozilla connected to both servers in non
secure mode (e.g. AUTH LOGIN)
6.If you use 'get new messages' on the first account, the logs will show a
secure mode (e.g. AUTH CRAM-MD5)
Actual Results:  
All authentications were insecure (or the same as the active account?)

Expected Results:  
Connect to each server using the method the user selected in the account.

Comment 1

14 years ago
I can't confirm this with my own two server setup in a fresh profile.
Could you attach your logs here?
(Reporter)

Comment 2

14 years ago
My scenario used 3 accounts with exactly the same server but different logins.

But forget it. I analysed the logs another time and found the missing secure
authentications. I was probably misled by the mixing of the connections in the
log file. Even the prefixed number is the same. Can't that be somehow changed?

Speaking of this bug, MailNews works correctly.
Sorry for your time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 3

14 years ago
No problem.
And yes, logs of multiple mail gets are confusing. They're logged in the order
they occur. The objects address or something like that in the prefix would be
nice. But currently it cannot be changed without recompile.
(Reporter)

Updated

14 years ago
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.