The page source command does not support self closed tags: eg <script present="false" />

RESOLVED WORKSFORME

Status

()

Toolkit
View Source
--
trivial
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Alastair Cooper, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

This is the first time I have developed XML/XSL and viewed it primarily in
Firefox. I noted that when looking at the page source for the base xml file that
self-closed tags cause the colouring scheme to become broken.

I tested this bug using a test html page and the tag <hr /> and the problem is
not apparent for HTML.

Firefox reproduces the problem under Linux/Windows XP Home and regardless of
whether the XML page references an XSL stylesheet.

Reproducible: Always
Steps to Reproduce:
1. Point firefox to an XML/XSL file that uses tags like <script present="false" />
   or <xsl:apply-templates />
2. Use the View Page Source command in the View menu
3. Observe that the purple tag colouring is broken after the self-closed tag
4. Curse petty oversights for blighting an excellent product!!!

Actual Results:  
On my page the data represents the names of tests, the colouring was repaired
after the next text element that used the whole <script>XXXXXXXXXXXX</script>
syntax. This meant that any element in the middle was discoloured

Expected Results:  
The software should perform as it does for an HTML page, producing the name of
each tag entity in purple and any CDATA in black

I do not use a theme, just the stock firefox show source code code.

No crash or loss of critical performance is associated with the bug, just
aesthetics!

Comment 1

14 years ago
I'm not seeing this with simple tests

data:text/xml,<document attribute='a'><sometag attribute='b'><nocontent
attribute='c'></nocontent><empty attribute='d' /><anothertag
attribute='e'>content</anothertag></sometag></document>

(put that in the address bar to view it)

Do you think you can provide an example?

Comment 2

14 years ago
Marking worksforme. If you still see this, please reopen it and if you can give
a testcase that shows the problem. 

(also moving to the view source component since that's where it should have been)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Component: Menus → View Source
Resolution: --- → WORKSFORME

Updated

12 years ago
QA Contact: bugzilla → view.source
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.