bookmarks toolbar items need an icon for the customize toolbar dialog

VERIFIED FIXED in Firefox0.9

Status

()

Firefox
Toolbars and Customization
--
enhancement
VERIFIED FIXED
14 years ago
11 years ago

People

(Reporter: miahz, Assigned: miahz)

Tracking

({fixed-aviary1.0, polish})

unspecified
Firefox0.9
fixed-aviary1.0, polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed0.9)

Attachments

(3 attachments)

(Assignee)

Description

14 years ago
User-Agent:       
Build Identifier: 

there is no icon for the personal bookmark toolbar items when in the customize
palette.

there is no indication that the bookmarks flex to fill the toolbar.

Reproducible: Always
Steps to Reproduce:
1. enter toolbar customize mode
2. drag bookmarks into palette
Actual Results:  
all you see is "Bookmarks" with no icon

Expected Results:  
an icon or some better visual representation of what the item is
(Assignee)

Comment 1

14 years ago
Created attachment 142036 [details]
image illustrating bug, and potential remedies

1. current broken state in palette. no icon. same label as bookmarks sidebar
button.
2. fixed existing code. same label as bookmarks sidebar button. not apparent
that this is the personal bookmarks toolbar item.
3. restyled to use more descriptive label, with appearance more suggestive of
functionality.

4. current state on toolbar during customize. no indication of space taken by
the whole item.
5. how it would look restyled using same fix as "3" with borders showing size
of object similar to a flexible space.
(Assignee)

Comment 2

14 years ago
Created attachment 142038 [details] [diff] [review]
patch fixing existing code to show icon in palette

the code for the bookmark toolbar was already in
classic/skin/classic/browser/browser.css, it was just slighty incorrect.  this
one line patch corrects it as shown in "2" in the image in comment #1.
(Assignee)

Comment 3

14 years ago
Created attachment 142040 [details] [diff] [review]
patch restyling bookmarks toolbar items

this patch makes the changes as shown in "3" and "5" in the image attached to
comment #1.  it uses the same, more descriptive label in the palette as used on
the toolbar.  the standard "Bookmarks" palette item label is removed.  borders
are also added to illustrate the size of the bookmarks while on the toolbar.

i would recommend this patch be used.
- uses better label
- item appears similar both in palette and on toolbar
- eliminates potential confusion caused by this having the same label as the
bookmark sidebar button
- true size of item on toolbar is apparent with borders, which will help when
positioning items and should help prevent items from being "lost" when added
after the bookmarks

Comment 4

14 years ago
Comment on attachment 142038 [details] [diff] [review]
patch fixing existing code to show icon in palette

Blake, do you like that approach?
Attachment #142038 - Flags: review?(firefox)

Comment 5

14 years ago
Comment on attachment 142040 [details] [diff] [review]
patch restyling bookmarks toolbar items

Blake, do you like that approach?
Attachment #142040 - Flags: review?(firefox)

Comment 6

14 years ago
Confirming. Assigning to miahz.
Assignee: bugs → miahz
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Summary: bookmarks toolbar items is broken during customize / in the palette → bookmarks toolbar items need an icon for the customize toolbar dialog
Target Milestone: --- → Firefox0.9
Comment on attachment 142040 [details] [diff] [review]
patch restyling bookmarks toolbar items

lets go ahead a file a separate bug about the styling against
arvid@quadrone.org
Attachment #142040 - Flags: review?(firefox) → review-
Comment on attachment 142038 [details] [diff] [review]
patch fixing existing code to show icon in palette

as noted, the styling should go to arvid for decisions, but in the absence of
that, lets get this in so we're not broken
Attachment #142038 - Flags: review?(firefox) → review+
checked in branch and trunk, thanks for the patch!

Please file a followup bug for Arvid to look at the styling here.
Keywords: polish
Whiteboard: fixed0.9
resolving FIXED, please note the followup bug here if/when filed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

14 years ago
thanks, mike.  something must be up with myrealbox email, cuz i haven't gotten
any mail in a couple days - i read about this checkin in the nightly build forum
thread.  i'll whip up the new bug as soon as i can.
(Assignee)

Comment 12

14 years ago
It's broken again.  I just looked at it, and the fix is the exact same thing as
last time, though the patch might be off by a line or so.  How did the theme get
back-graded to where this was unfixed?

Needs to be reopened (i don't think i'm strong enough to change it).  And now
maybe the alternate second patch can be reconsidered.

Actually, just checked, and the bookmark folder icon image
(chrome://browser/skin/Bookmarks-folder.png) isn't in the theme anymore.  (Yet
another reason to go with the second approach - it uses the normal bookmark
icon.)  But that doesn't explain why the code backed up.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
*** Bug 206159 has been marked as a duplicate of this bug. ***

Comment 14

13 years ago
I can reproduce this bug in my system Windows XP. Here is my configuration:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

Updated

13 years ago
Keywords: fixed-aviary1.0
(Assignee)

Comment 15

13 years ago
This (along with a few other bugs) was tagged as fixed-aviary1.0, but is not
truly fixed.  browser/Bookmarks-folder.png was checked in, but it is corrupt or
something - it does not display and will not open in any image viewer/editor i
tried.

Still broken.

17th/Windows 2000 [Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3)
Gecko/20041017 Firefox/1.0]

Comment 16

13 years ago
The icon is displayed just fine here:
http://lxr.mozilla.org/seamonkey/source/browser/themes/winstripe/browser/Bookmarks-folder.png
http://lxr.mozilla.org/seamonkey/source/browser/themes/pinstripe/browser/bookmarks/bookmark-folder.png

Marking fixed again.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → FIXED
v.
Status: RESOLVED → VERIFIED

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.