If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Use HKCU instead of HKLM for default browser settings on XP

RESOLVED FIXED in Firefox1.0beta

Status

()

Firefox
Shell Integration
P2
enhancement
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: Bernie Zimmermann, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({fixed-aviary1.0})

unspecified
Firefox1.0beta
x86
Windows XP
fixed-aviary1.0
Points:
---
Bug Flags:
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

I am currently unable to run Firefox as my default browser because my girlfriend
likes to use Internet Explorer.  We have two separate Administrator accounts on
Windows XP, and for some reason when I set Firefox as my default browser, it
gets set as the default under her account as well.  It is my opinion that
default browser settings should be on a per-account basis, and setting my
default browser to Firefox should not change her default setting of Internet
Explorer.

Reproducible: Always
Steps to Reproduce:
1. Set Firefox as the default browser under one Windows XP account
2. Login under another Windows XP account on the same machine
3. Go to Start, Run and type in www.mozilla.org and hit OK
Actual Results:  
URL opens in Firefox instead of IE (or whatever the default browser was for that
account).

Expected Results:  
The 2nd account's default browser setting should have persisted, and the URL
should have opened in IE (or whatever the default browser was for that account).

Comment 1

14 years ago
I'm pretty sure this is a limitation of Windows, I think the default browser is
a global setting.
(Reporter)

Comment 2

14 years ago
Regarding comment 1, I was really hoping you wouldn't say something like that ;)

I did a little Googling and found a somewhat ambiguous thread on the subject at
http://www.annoyances.org/exec/forum/winxp/t1038583704

I'll try messing with the customized Set Program Access and Defaults settings
when I get home and update this bug depending on my findings.
(Reporter)

Comment 3

14 years ago
I went to Set Program Access Points and Defaults (located under Control Panel ->
Add/Remove Programs) tonight, but was unable to set Firefox as the default
browser on my account and leave IE as the default on my girlfriend's account.  I
tried several combinations of the Custom setting.  I noticed at least once that
when I tried to set Firefox as the default using that Custom dialog, the process
basically hung and never finished.  Anyone know if Firefox knows how to handle
that method of setting it as the default (if it even should)?

I'd be interested if anyone else has played around with these settings and knows
how to set Firefox as the default on one account and not another.

Comment 4

14 years ago
related Bug 220865

Comment 5

14 years ago
Related info in thread:
http://forums.mozillazine.org/viewtopic.php?t=65432

Specifically, the following quotes:
"then the other members of your family can login with their usernames and choose
their settings desktop,browser, e-mail client whatever they want...
This are per user settings [...] (This work on every windows OS that I have try
before Windows 98/ME, Windows XP, Windows Server 2003)"

"Yup, but this is a error from the Devs of Firefox they should write the
HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Desktop
key to the
HKEY_CURRENT_USER\SOFTWARE\Mozilla\Desktop"
per http://support.microsoft.com/default.aspx?scid=kb;en-us;299853 this is only
supported on XP.  However, its worth considering.  This would be useful to me
since my wife really hates buggy nightlys :)

-> ben for consideration

This isn't really a bug, since this is how its worked until XP, the fact that we
can now implement something XP-specific is an enhancement.
Assignee: firefox → bugs
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: mconnor
Summary: Setting Firefox as default browser propagates to other XP accounts → Use HKCU instead of HKLM for default browser settings on XP

Updated

14 years ago
Component: General → Preferences

Comment 7

14 years ago
*** Bug 220865 has been marked as a duplicate of this bug. ***
*** Bug 238507 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Component: Preferences → OS Integration
Flags: blocking1.0+
Priority: -- → P2
Target Milestone: --- → Firefox1.0beta
Created attachment 152043 [details] [diff] [review]
patch

1 - add a parameter to setDefaultBrowser/restoreSettings to allow the operation
to occur for all users (true) or just the current user (false) - and update
call sites.
2 - per-user keys may not exist, so make a new "OpenUserKeyForReading" function
that first looks for a user key, then falls back on an all-user key. 
3 - create a function that properly checks access privileges when opening a key
and returns a result that call sites can check for, update call sites to use
these new functions.
4 - update terminology throughout file to indicate new preference for HKCU vs.
HKLM. 
5 - fix bug caused by bsmedberg - add shellservice.properties to new locales
jar.mn
I believe this to be fixed, br & trunk. 
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 11

13 years ago
We actually do set it as default for all users in one case?  Wow.

Comment 12

13 years ago
The patch for this bug may well implement the change described in the summary of 
this bug, but Reporter of this bug has verified to me in email that his problem 
still exists:  individual users on the system are forced to share the "default" 
client (of any sort: browser, mail, media player, etc).

This is a problem with Windows itself; see bug 220865 comment 6.

Updated

13 years ago
Keywords: fixed-aviary1.0

Comment 13

13 years ago
According to 
http://www.microsoft.com/windows2000/techinfo/reskit/en-us/regentry/69673.asp?frame=true

Windows uses the information of HKEY_CLASSES_ROOT to determin which programs to
start. 

As of windows 2000:
"The content of HKEY_CLASSES_ROOT comes from two sources:
HKEY_LOCAL_MACHINE\SOFTWARE\Classes and HKEY_CURRENT_USER\SOFTWARE\Classes. If a
subkey or entry appears in either location, it also appears in
HKEY_CLASSES_ROOT. If the values of entries in the two Classes subkeys conflict,
only the value in HKEY_CURRENT_USER\SOFTWARE\Classes appears in HKEY_CLASSES_ROOT."

Conclusion: HKLM for system default and HKCU for user default
and check for default in HKCR
is this a dupe of 220865?
sorry. my error :(
You need to log in before you can comment on or make changes to this bug.