Changing sender account should check digital signature/encryption preferences

RESOLVED DUPLICATE of bug 230420

Status

MailNews Core
Composition
--
minor
RESOLVED DUPLICATE of bug 230420
14 years ago
10 years ago

People

(Reporter: Andreas Lange, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040107

It is possible to set that new mails from certain accounts should always be
digitally signed and/or use encryption. This is used when composing a new mail
from those accounts. However, it is not checked when changing sender after the
compose window has been opened.

Reproducible: Always
Steps to Reproduce:
1. Open new compose for account without default signing
2. Change sender to account with default signing


Actual Results:  
GUI is not updated to indicate that the message will be signed, message is sent
without getting signed.

Expected Results:  
Upon switching account, set/unset digital signing according to account preferences.

As far as I can see, there is already some check for this since if you do it in
the opposite way (1. open for account with default signing, 2. change to account
without) the signature is removed from the message (since there is now a
mismatch between certificate and sender address).

This is not a major problem since it is easy to self set sign/encryption after
switching account. One tends to get lazy and forget that though since it works
according to the preferences if one gets the account right from the beginning. :-)

Comment 1

14 years ago
This is by design and I don't think that will change.

*** This bug has been marked as a duplicate of 230420 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.