Make the filter dialog size in proportion to the font size

RESOLVED FIXED in mozilla1.7beta

Status

MailNews Core
Filters
--
trivial
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: Scott MacGregor, Assigned: Stefan Borggraefe)

Tracking

Trunk
mozilla1.7beta

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

14 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=233028#c10

Thanks for looking into this Stefan!
(Reporter)

Comment 1

14 years ago
Created attachment 142170 [details]
screen shot of the problem with large fonts
(Assignee)

Updated

14 years ago
Severity: normal → trivial
Status: NEW → ASSIGNED
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → mozilla1.7beta
(Assignee)

Comment 2

14 years ago
Created attachment 142215 [details] [diff] [review]
Patch

The FilterListDialog also has a default size that is not proportional to the
used font size. This patch fixes both dialogs.
(Assignee)

Updated

14 years ago
Attachment #142215 - Flags: review?(neil.parkwaycc.co.uk)

Comment 3

14 years ago
Comment on attachment 142215 [details] [diff] [review]
Patch

Could you reduce those sizes slightly, e.g. 48em to 45em?
(Assignee)

Comment 4

14 years ago
Created attachment 142337 [details] [diff] [review]
Patch V1.1

Ok, I reduced the sizes a little bit. This should still fit.

FYI: The configuration which needed the most space in my tests was Classic
mozilla-theme on a Linux gtk1 build with the Geramik gtk-theme. This
configuration needed even more space than using Classic with Windows XP.
(Assignee)

Updated

14 years ago
Attachment #142215 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #142215 - Flags: review?(neil.parkwaycc.co.uk)
(Assignee)

Updated

14 years ago
Attachment #142337 - Flags: review?(neil.parkwaycc.co.uk)

Comment 5

14 years ago
Comment on attachment 142337 [details] [diff] [review]
Patch V1.1

I've just twigged that the old width= height= dimensions apply to the outer
dimensions, but the styled dimensions apply to the inner dimensions; this
doesn't matter much for the width but the window still looks too tall because
of the title bar. Please could you shorten both windows another couple of em?
(Reporter)

Comment 6

14 years ago
*** Bug 235699 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

14 years ago
Created attachment 142352 [details] [diff] [review]
Patch V1.2

Reduced height of both windows by 3em.
Attachment #142337 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #142337 - Flags: review?(neil.parkwaycc.co.uk)
(Assignee)

Updated

14 years ago
Attachment #142352 - Flags: review?(neil.parkwaycc.co.uk)

Comment 8

14 years ago
Comment on attachment 142352 [details] [diff] [review]
Patch V1.2

Goldilocks and the Three Patches... this one's Just Right ;-)
Attachment #142352 - Flags: review?(neil.parkwaycc.co.uk) → review+
(Reporter)

Comment 9

14 years ago
Comment on attachment 142352 [details] [diff] [review]
Patch V1.2

lol...thanks a lot guys
Attachment #142352 - Flags: superreview+
(Assignee)

Comment 10

14 years ago
Scott: Could you check this in (and perhaps the patch for bug 223295, too)?
Thanks! :-)

After some web-searching I now know about Goldilocks, too. She's unknown in
Germany or at least to me. So at least I learned something new by doing *three*
patches for this bug. ;-)
(Reporter)

Updated

14 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.