Address bar dropdown button fails if any textbox has focus

RESOLVED DUPLICATE of bug 240095

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 240095
14 years ago
13 years ago

People

(Reporter: Bernie Zimmermann, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

While working on a theme for Firefox I noticed that the addressbar history would
always flicker open and closed really fast if the first thing I did after
launching the app was to click on the down arrow at the right of the addressbar.
 At first I thought it might have been something I introduced while working on
the theme, so I verified it tonight using the default Firefox theme.

Reproducible: Always
Steps to Reproduce:
1. Open up a new instance of Firefox
2. Immediately click on the down arrow in the addressbar

Actual Results:  
The addressbar history (box of previously typed-in URLs below the addressbar)
flickers open and closed really quickly, and the addressbar history is not
displayed properly.

Expected Results:  
Addressbar history should have opened up just as it does on all subsequent
clicks of the down arrow.

It is important that clicking the addressbar's down arrow be the very first
thing you do after Firefox has been launched.
( Hariprasad Kantubhukta,  Feb 26,2004)

I could replicate the bug only when Firefox is the "default browser" on

Configuration:
Hardware: PC 
Operating System:  Windows XP

Build:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Another form of the bug on the same configuration and build: 
Steps to reproduce:
1)Open a page that contains a text box

2)Click inside the box. (ie., get the focus into the text box)

3)Immediately click on the address bar’s down arrow

Actual result: Address bar flickers open and closed really quickly

Expected result: Address history should be shown.

Reproducible: Sometimes
Bug not seen in the following cases:
1 .If the initial click is in a multi-line text box
2. If the initial click is in a text box for some passwords
(Reporter)

Comment 2

14 years ago
Just for clarification's sake, Firefox is not the default browser on my system
and I still see the incorrect behavior.  I have no additional themes or
extensions installed whatsoever.
(Reporter)

Comment 3

14 years ago
I just confirmed that this bug occurs in the Macintosh version of Firefox 0.8 as
well, so I'm guessing this is a general Firefox bug (i.e. it isn't OS dependent).

I'm setting this as blocking1.0? since it seems like an important fix to get in.
Flags: blocking1.0?

Comment 4

14 years ago
I am not sure, but I think this may happen as a result of the page loading. I
opened a new window and clicked the arrow and as soon as it finished loading,
the address bar history closed. The reason it is going so fast for you is
probably because you have a faster connection than mine (56k). I will leave this
bug as unconfirmed for now...
WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

14 years ago
What version does it work for you in, Peter?  I'm using 1.0PR and the problem
still persists.

Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

Comment 7

14 years ago
Bernie, what ia your connection speeD???
(Reporter)

Comment 8

14 years ago
Broadband - roughly 1Mbps DSL.

Comment 9

14 years ago
I think this is cause by the page loading...I dont believe this is a bug...I
will close this bug
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 10

14 years ago
You're kidding, right?  Whether the problem is caused by the page loading,
Firefox starting up, the throbber spinning, or a goat dancing, this is a bug
that needs to be fixed.

If I click on the address bar dropdown, I'm doing it for a reason.  I want to
see the history of addresses so I can go to a site.  The only reason I could see
for leaving this bug as is is if it were by design...but if that's the case I'd
really like to have a word with whoever came up with the design.

In my opinion the bug has nothing to do with the page loading.  I have Google
(www.google.com) set as my home page.  I start up Firefox 1.0PR and wait for the
page to load.  After it loads, I can wait a minute if I want and then click the
address bar dropdown.  The address bar quickly appears and just as quickly
disappears.  This is a bug.

Please, someone reopen this bug.  It's an annoying one that, while not major,
would be nice to have fixed by 1.0.

Comment 11

14 years ago
See you never implied that it happens even if the page is loaded...
I will reopen bug.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 12

14 years ago
Confirming bug with

Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

For me the bug occours only if you click on the button rather quickly (less than
2 seconds after opening firefox).
However, the address bar doesn't open-close quickly, but there's a 3-4 seconds
gap between open and close.
->NEW

(unco ?1.0 doesn't make any sense)
Status: UNCONFIRMED → NEW
Ever confirmed: true
tricky to replicate on a faster system, this is not anywhere near a blocker,
especially at this stage.
Flags: blocking-aviary1.0? → blocking-aviary1.0-
(Reporter)

Comment 15

14 years ago
"tricky to replicate on a faster system"

Just to clarify, I'm seeing this bug on a P4 3GHz machine with 512MB RAM.  It is
very easy to reproduce.
*** Bug 262435 has been marked as a duplicate of this bug. ***
Created attachment 161126 [details]
testcase - focus an input

Interesting that people find this difficult to reproduce, and require complex
actions and connection speeds. Based on the reporter in bug 262435 saying he
only sees it with Google as his home page, I just trimmed them down to a
testcase: an <input>. Click in it to give it focus, then click the addressbar
dropdown. Apparently it's listening a little too hard for onblur(), because
(for me) every single time, if the input has focus the addressbar will show and
then hide right away. No first time, no timing required, just focus and click.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041004
Firefox/0.10.1, clean and clean.

Comment 18

14 years ago
This happens even with the built-in search feature, just click the search field
so that it gets the focus and then click the url-bar dropmarker. It'll collapse
the history immediately.
*** Bug 259917 has been marked as a duplicate of this bug. ***

Comment 20

14 years ago
Didnt know there was a duplicate.

But to also clarify, my homepage is google also and I get the same results: Open
a window, do nothing (not even clicking inside a blank spot in the window), then
click/release the menu arrow quickly, and it flashes open/closed.  Then the
window behaves normally, with the bar remaining open even on quick button
release. Doesnt do this when a new tab is opened, only a new browser window,
including a second window, or if the mouse button is held down.

Whether or not its a bug, it is inconsistant behavior.

Updated

13 years ago
Summary: Addressbar history does not open correctly when opened right after app startup → Address bar dropdown button fails if any textbox has focus

Comment 21

13 years ago
*** Bug 263221 has been marked as a duplicate of this bug. ***

Comment 22

13 years ago
*** Bug 261720 has been marked as a duplicate of this bug. ***

Comment 23

13 years ago
This bug and bug 240095 are the same bug.  Bug 240095 has more votes and is
better-reported, so I'm marking this one as a dup even though it's older.

*** This bug has been marked as a duplicate of 240095 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.