If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

M17x FF10 [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming using Real Player plugin

VERIFIED WORKSFORME

Status

Plugins Graveyard
RealPlayer (Real)
--
critical
VERIFIED WORKSFORME
14 years ago
a year ago

People

(Reporter: warren, Unassigned)

Tracking

({crash, qawanted, topcrash})

Details

(crash signature, URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040113

MOZILLA caused an invalid page fault in
module NPPL3260.DLL at 0177:61544341.
Registers:
EAX=00000000 CS=0177 EIP=61544341 EFLGS=00010202
EBX=00000000 SS=017f ESP=0066336c EBP=006633c0
ECX=00663388 DS=017f ESI=037628c4 FS=3267
EDX=006633bc ES=017f EDI=03762900 GS=0000
Bytes at CS:EIP:
8b 08 ff 51 14 85 c0 74 3b be 05 00 00 00 8b 45 
Stack dump:
00000000 006633bc 00000000 037628a0 037628c4 02f193a4 03595590 10044200 0787f090
0187f000 0700002c 006897d8 ffffffff 00000000 00000000 00000000
______________________________________________________________
During the live steaming of the free video film clips - crashes everytime
without exception.

Reproducible: Always
Steps to Reproduce:
1. goto www.bdmax.com
2. click on "Yes I agree..."
3. click on "steaming video" button
4. click on "Free bondage video clip - changes daily"
5. wait for the stream to load
6. MOZILLA caused an invalid page fault in module NPPL3260.DLL at 0177:61544341.
7. without exception


Actual Results:  
Mozilla crashes

Expected Results:  
live streaming video film clip

Updated

14 years ago
Severity: normal → critical
Component: Browser-General → Plug-ins
Keywords: crash
which Realplayer Version Do you use (see help/about plugins) ?
This looks like a bug in the realplayer..

Comment 2

14 years ago
*yuck* ;o)

WFM - latest talback enabled build + real player 10.0 plugin under WinXP-SP1

Comment 3

14 years ago
This has been a topcrash for a loooong time.  It's a Real Player crash, so not
sure if there is much we can do about it.  Possible workaround for these types
of crashes is to try the latest version of the plugin (a lot of old crashes with
Real Player, Flash and QuickTime plugins are usually fixed by using the most
recent version).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: topcrash
Summary: NPPL3260.DLL crashes under live streaming on the above listed website without exception → M17rc1 [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming on the above listed website without exception

Updated

14 years ago
Summary: M17rc1 [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming on the above listed website without exception → M17rc2 [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming on the above listed website without exception

Updated

14 years ago
Depends on: 242295

Comment 4

13 years ago
M17rc2 -> M17 (still a topcrasher with Mozilla 1.7 final)
Summary: M17rc2 [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming on the above listed website without exception → M17 [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming on the above listed website without exception

Comment 5

13 years ago
This is a topcrash with Firefox 0.9.1 as well.  I wonder if this is only an
issue with older versions of Real Player and other similar plugins (many of the
Talkback reports mention RealAlternative (www.free-codecs.com))...

If people are crashing, please post your plugin and version.

So far:

Real Player 10 - no crash
real alternative 1.23 - crash
Summary: M17 [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming on the above listed website without exception → M17 FF091 [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming on the above listed website without exception

Comment 6

13 years ago
Doesn't look like installing the latest version of Real Player fixes this crash.
 I see a few comments in the Talkback data that mention installing RealPlayer 10
before crashing.  Many other users continue to say they were using the
RealAlternative plugin.

For more incidents, you can go to:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=NPPL3260.DLL
Summary: M17 FF091 [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming on the above listed website without exception → M17 FF092 [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming on the above listed website without exception

Comment 7

13 years ago
Adding qawanted keyword to see if we can get more people to test this and
provide more info about what versions/plugins they are using to cause this
crash.  Marking topcrash- until we get a better handle on this.
Keywords: topcrash → qawanted, topcrash-
OS: Windows 98 → All
Summary: M17 FF092 [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming on the above listed website without exception → M17 FF09x [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming on the above listed website without exception

Comment 8

13 years ago
*** Bug 255436 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
as a comment on http://bugzilla.mozilla.org/show_bug.cgi?id=255436 on the
http://www.bbc.co.uk/radio1/ crash which was marked a dup of this bug, bart
mentioned that the person upgrade to 10.5 beta and now it works with no crash.

Updated

13 years ago
Summary: M17 FF09x [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming on the above listed website without exception → M17x FF10PR1 [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming on the above listed website without exception

Comment 10

13 years ago
*** Bug 263147 has been marked as a duplicate of this bug. ***

Comment 11

13 years ago
*** Bug 258066 has been marked as a duplicate of this bug. ***

Comment 12

13 years ago
*** Bug 263170 has been marked as a duplicate of this bug. ***

Comment 13

13 years ago
Still happening with Firefox 1.0 RC1 and RC2.  Perhaps we should add a relnote
telling people to upgrade to Real Player 10.5 beta (as mentioned in comment #9)
to avoid this crash?
Summary: M17x FF10PR1 [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming on the above listed website without exception → M17x FF10RC2 [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming on the above listed website without exception

Comment 14

13 years ago
Still around in Firefox 1.0.  

Has anyone had any luck preventing this crash by upgrading their Real Player?
Keywords: topcrash- → topcrash
Summary: M17x FF10RC2 [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming on the above listed website without exception → M17x FF10 [@ nppl3260.dll][@ NPPL3260.DLL] crashes under live streaming using Real Player plugin

Comment 15

13 years ago
Hi,

Yeah - I went from Real Alternative (not sure what version, but around 3 months
ago) to regular Real Player 10, and it all works OK (including BBC radio applet
and Reuters TV). Not sure if a more recent version of Real Alternative fixes
this  last I looked it didn't look like they had changed to a newer dll which
(according to a dupe bug) was suggested as the cause of the problem.

Real Alternative works with these sites in IE6 (Opera anyone?), so it's not a
Real Alternative bug (not directly anyway!).

This is an important bug - as the audience likely to favor a light, bloat-free
browser would also often favor a light, bloat-free hack of popular media players!!

- Grug

Comment 16

13 years ago
No problem dude, Use WMP, there will be no crash.

Comment 17

13 years ago
(In reply to comment #16)
> No problem dude, Use WMP, there will be no crash.

but that was with 1.8b2
jay, perhaps you can verify...
WFM Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/2007060809 SeaMonkey/2.0a1pre
and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
using http://www.bbc.co.uk/radio1/

(reporter is gone)

FWIW talkback has some crashes for nppl3260 (rank 425 for FF 2.0.0.4) and it points to bug 158670
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 19

10 years ago
verified wfm, doesn't look like this crash is as visible as it was before.  if we see it move up in the topcrash rankings, we can reopen or just log a new bug with fresh steps or a testcase.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Plug-ins → RealPlayer (Real)
Product: Core → Plugins
QA Contact: general → real-player
Version: Trunk → unspecified
Crash Signature: [@ nppl3260.dll] [@ NPPL3260.DLL]
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.