[mozTXTToHTMLConv] Linkifying Email addresses misses the end of the address, when followed by punctuation marks

RESOLVED WORKSFORME

Status

MailNews Core
Backend
--
minor
RESOLVED WORKSFORME
15 years ago
5 years ago

People

(Reporter: Konstantin Vainer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040125

subj

Reproducible: Always
Steps to Reproduce:
1. compose email, write in body "some@email.address.com: this email address will
not be linkified properly"
2. send the email to yourself (as plaintext)
3. enjoy the result...

Actual Results:  
"some@email.address.com:" will be linkified

Expected Results:  
"some@email.address.com" should be linkified

Did not commit full testing with all the punctuation marks as well as simply
non-white-space chars, but i guess that will also be a problem, should
definitely review the matching (regex?)
(Reporter)

Comment 1

15 years ago
Update:

tested the following chars:
.,:;?!<>/\[]{}()$%^&*-=+_|~`'"

mozmailer linkified address correct with these:
.,;?!`'"<>]})|

all the rest results in behavior i described

Comment 2

15 years ago
wfm with Firefox nightly 20040224 Win2k

Comment 3

15 years ago
Benedikt, how could this be WFM in Firefox which is a _browser_?

Confirming bug in Linux build 2004021909, though I'm not sure that it's a bug,
not a feature.
btw, to reproduce it's enough to save the mail and then inspect it in the Draft
folder.

Comment 4

15 years ago
Ah... Well I think I was sleepwalking when I wrote that comment.. I obviously
didn't read the bug carefully enough.

Sorry for that.
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

13 years ago
(In reply to comment #1)
> tested the following chars:
> .,:;?!<>/\[]{}()$%^&*-=+_|~`'"
> 
> mozmailer linkified address correct with these:
> .,;?!`'"<>]})|

By "linkified correct" you mean "didn't include the character" -- but in fact, 
many of those characters are *legal* in both mail addresses and URLs.  

It appears that recognition does not distinguish between addresses and URLs 
while parsing.  RFC 2822 seems to offer extremely wide latitude on what is legal 
within an address or domain name.
  <http://rfc.net/rfc2822.html#s3.4.1.>

For the case of URL recognition including characters it probably shouldn't -- 
especially  [{\^  -- there is bug 218287, and this bug is potentially a dupe of 
that one.
For the case of not including characters that arguably should -- notably  '()  
-- there is bug 133016.

But if mail addresses should be more restricted -- especially regarding chars in 
the final position -- then this bug could remain open.
Assignee: mail → nobody
Severity: normal → minor
Component: MailNews: Main Mail Window → MailNews: Backend
OS: Windows XP → All
Product: Mozilla Application Suite → Core
QA Contact: esther
Hardware: PC → All
Summary: Linkifying Email addresses misses the end of the address, when followed by punctuation marks → [mozTXTToHTMLConv] Linkifying Email addresses misses the end of the address, when followed by punctuation marks

Updated

10 years ago
QA Contact: backend
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 7

5 years ago
This is no longer an issue. WFM on current trunk.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.