Root needed to install search engines

RESOLVED DUPLICATE of bug 123315

Status

()

--
major
RESOLVED DUPLICATE of bug 123315
15 years ago
14 years ago

People

(Reporter: hardy, Assigned: bugzilla)

Tracking

unspecified
x86
FreeBSD
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.6) Gecko/20040213 Firefox/0.8

It appears that in order to install themes, extensions or other search engines,
one needs to have access to the actual installation

Reproducible: Always
Steps to Reproduce:
1. Install on Linux or BSD
2. Try to add engines as a normal User
3. Try to do it as root

Actual Results:  
If you try as user, you do not even get forwarded to mycroft. As root,
everything works.

Expected Results:  
All extensions etc. should really be installed into ~/.phoenix/ since on a well
administrated system nobody except root should have write-access to Firefox itself.

Comment 1

15 years ago
With search engines I can confirm this. I made the searchplugins directory
writeable in the firefox directory to get around this.
See also comments I made in bug:

Most extensions you can also install in the profile. The extension writer can
choose what he wants to support. I'm personally in favor of doing only giving
the option to install in the profile, because you do not have to uninstall
firefox when extensions totally bork firefox.

The biggest problem is that this operation fails silently, at least for search
plugins.  An explanatory dialog box with a link to
http://mycroft.mozdev.org/deepdocs/installing.html would be a decent band-aid
until a real fix is possible.

Comment 3

15 years ago
I can also confirm this, with regards to adding a search engine using 0.8 under
Linux. I think having the search engines added to a user's profile is the best
answer, since not all users will want the same search engines in their drop down
menu. However, I think it is also a good idea, like most 'normal' extension
allow, for the user to either install in their profile, or install globally [and
be prompted for a root passwd].

Just my $.02.

/vjl/

Updated

15 years ago
Flags: blocking1.0?

Comment 4

15 years ago
This bug should go away with the new extension manager in 0.9.

Comment 5

15 years ago
(In reply to comment #4)
> This bug should go away with the new extension manager in 0.9.
For extensions and themes yes. It will only be possible to install them in the
profile. AFAIK there will be no changes to the search engines, so for that the
bug will remain until the search engines are also moved to the profile
The extensions/themes thing is covered by other bugs and is fixed on the branch.
I'm sure the search engines piece is a duplicate of something else, it's valid
though and we need to fix it but I won't be getting to it before 1.0. Patches
welcome. 
Flags: blocking1.0? → blocking1.0-
Summary: Root needed to install search engines , themes , extensions → Root needed to install search engines

Comment 7

15 years ago
(In reply to comment #6)
> The extensions/themes thing is covered by other bugs and is fixed on the branch.
> I'm sure the search engines piece is a duplicate of something else, it's valid
> though and we need to fix it but I won't be getting to it before 1.0. Patches
> welcome. 

searchplugins piece is duplicate of this one :
http://bugzilla.mozilla.org/votes.cgi?action=show_bug&bug_id=123315

Comment 8

15 years ago
(In reply to comment #6)
> The extensions/themes thing is covered by other bugs and is fixed on the branch.
> I'm sure the search engines piece is a duplicate of something else, it's valid
> though and we need to fix it but I won't be getting to it before 1.0. Patches
> welcome. 

searchplugins piece is duplicate of this one :
http://bugzilla.mozilla.org/show_bug.cgi?id=123315

Comment 9

14 years ago
This bug can be resolved as a duplicate of bug #123315
The theme / extension part of this bug has been solved in FF 0.9. So only the
search engine part needs to be resolved and that is bug #123315
Agreed. The solution to this is to install the search engines in the profile.

*** This bug has been marked as a duplicate of 123315 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.