Wanted: Open links that requiest a new window in a tab instead

RESOLVED DUPLICATE of bug 105547

Status

SeaMonkey
Tabbed Browser
--
enhancement
RESOLVED DUPLICATE of bug 105547
15 years ago
5 years ago

People

(Reporter: Toralf Lund, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031030 Epiphany/1.0.4

I thought there was an entry for this already, but I didn't find one - even
thought there are *lots* that touch on the subject, so here I go:

It would be nice to have some way to open all URLs that currently open in new
tabs instead window in new *tabs*. This includes open via <a href=...
target="_blank"> and external references opened via remote call openurl(...,
new-window)

Simply put, I'd like to have *one* browser window, and pretend tabs are windows
for the purpose of "open-window" calls, if you know what I mean.

Nicetohave:

When using workspaces e.g. on Linux, have one window per workspace rather than
one in total; let openurl(..., new-window) open a *window* iff there is no other
browser window on that workspace, otherwise a tab.

BTW, I think there is a Firebird extension that tries to this, but it didn't
work very well the last time I tried, and I think something like this needs to
be supported in the browser core.

Reproducible: Always
Steps to Reproduce:
This is a duplicate.
Whiteboard: DUPEME

Comment 2

15 years ago
Duping to bug 105547, which is the target=blank to new tab bug.

JavaScript opening to tab is bug 103843.

*** This bug has been marked as a duplicate of 105547 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.