segfault when opening Calendar from Tools menu

RESOLVED DUPLICATE of bug 254399

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED DUPLICATE of bug 254399
15 years ago
14 years ago

People

(Reporter: James Hughes, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20040130 Firebird/0.7

Tbird crashes with Calendar (natively installed) open attempt from Tools menu.
gdb reports:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1083762176 (LWP 7147)]
0x40463bef in _gdk_window_move_resize_child () from /usr/lib/libgdk-x11-2.0.so.0

Calendar worked for a while but seemed to become confused after adding second,
publicly available, calendar. Tried Calendar nightly build, same problem.

Reproducible: Always
Steps to Reproduce:
1. Start Thunderbird.
2. Open calendar from tools menu.
3.

Actual Results:  
As reported above, segfaulted, in function _gdk_window_move_resize_child
according to gdb.

Expected Results:  
Not crashed :-)

Segfault in /usr/lib/libgdk-x11-2.0.so.0

...hmm, and ddd crashes when I ask it for a backtrace...

Comment 1

14 years ago
Created attachment 155334 [details]
backtrace after segfault in oeCollectedEventEnumerator::HasMoreElements()

Started Firefox 0.9.2-3.1.fc2.dag with '--debug -webcal' arguments. Collected
stack backtrace from DDD. Calendar build is from 2004-08-03.

Comment 2

14 years ago
I think my segfault might be similar, so I added a stack backtrace to this bug.
Hope this helps... :-/

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 254399 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.